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ANOTACE 

Tato bakalářská práce se věnuje seznámení s programem Autodesk Maya a zaměřuje se na 

jeho využití při práci s polygonovým modelováním. Cílem teoretické části práce je vytvořit 

přehlednou nápovědu za pomocí popisků, popsání možností nastavení, využívání klávesových 

zkratek a za pomoci ikon, obrázků a příkladů seznámit s polygonovým modelováním. Obecně 

vysvětlit jeho účel a použití při tvorbě počítačové 3D grafiky.  

Praktická část je zpracována webovou prezentací v jazyce HTML5 a PHP.  
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TITLE 

Simple help for Autodesk Maya III. 

ANNOTATION 

This bachelor thesis deals with the introduction to Autodesk Maya and focuses on its uses in 

work with polygon modeling. The theoretical part of the work is to create a clear hint for using 

labels, describing settings, use keyboard shortcuts and with the help of icons, images and 

examples meet with polygonal modeling. To explain the purpose and use in the creation of 3D 

computer graphics. 

A web presentation of Autodesk Maya help with HTML5 and PHP is processed in the practical 

part. 
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Terminologie 

Vztažný bod (Pivot point) – každý objekt v aplikaci Maya má vztažný bod. Otáčíte-li 

nějakým objektem, otáčí se tento objekt kolem svého vztažného bodu. Při změně velikosti se 

objekt zmenšuje směrem k vztažnému bodu, nebo se naopak od něj zvětšuje. Standardně se 

vztažný bod nachází ve středu objektu, nicméně Maya vám umožní přesunout vztažný bod tam, 

kam jej právě potřebujete. Tato vlastnost vám přijde vhod při tvorbě určitých druhů animací 

a pohybů. [4] 

Růžicové menu (Marking menu) – kontextová nabídka ve tvaru růžice. 

Barva na vrcholu (Color per vertex) – běžně se používá u 3D modelů, které jsou vytvořeny 

pro interaktivní videohry, aby účinněji simulovaly efekty stínování a efekty předsvícení. 

Alfa kanál (Alpha Channel) – Poskytuje informaci o průhlednosti obrázku. Bílá barva značí 

neprůhledné oblasti, černá plně průhledné oblasti. Stupně šedi pak více či méně průhledné 

oblasti. [9] 

Polygonová síť (polygon mesh, polyset) – Mnoho plošek spojených dohromady vytvoří síť 

plošek, která se nazývá polygonová síť (polygon mesh –⁠ také označovaná jako polyset). [7] 

Plášť (shell) – Nesouvislá sada spojených polygonů, ze které může být složena polygonová 

síť. [7] 

Primitivy (Primitives) – Trojrozměrné geometrické tvary, které můžete vytvořit v aplikaci 

Maya. K dostupným primitivním tvarům patří koule, krychle, válec, kužel, plocha a mnoho 

dalších. [7] 

Normála (normal) – Teoretická čára, kolmá na povrch polygonu. V aplikaci Maya se 

normály používají k určení orientace polygonové plošky (normály plošky – face normals). [7] 

Slepá data (Blind data) – Informace uložené s polygony, které Maya žádným způsobem 

nepoužívá, ale jsou užitečné pro platformu, na kterou exportujete polygony, jako je interaktivní 

herní konzole. [7] 

Trojstranný polygon (tri nebo triangle) – Trojúhelníkový polygon. Ve svých rozích má 

přesně 3 vrcholy a 3 hrany spojující tyto body. Toto je nejmenší konfigurace potřebná 

k vytvoření polygonové plošky. [13] 

Čtyřstranný polygon (quads nebo quadrilateral) – Čtyřúhelníkový polygon. Má přesně 

4 vrcholy v rozích spojených 4 hranami. Jedná se o nejžádanější typ polygonu při vytváření 

digitálních modelů. [13] 

  



N-stěn (n-gons) – Je polygon s více než čtyřmi vrcholy a hranami. Tento druh polygonu 

není žádoucí a měli byste se mu vyhnout. Díky svým geometrickým vlastnostem lze n-stěny 

vždy rozdělit na trojúhelníky, čtyřúhelníky nebo kombinaci obojího, takže je lze snadno 

odstranit přidáním spojovacích hran mezi vrcholky. [13] 
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Úvod 

Bakalářská práce se věnuje aplikaci pro tvorbu počítačové 3D grafiky za pomocí aplikace 

Autodesk Maya, přičemž se zaměřuje především na její využití pro polygonové modelování. 

Teoretická část bakalářské práce zpracovává podrobnou nápovědu pro práci s programem 

Autodesk Maya v oblasti polygonového modelování. Za pomoci vysvětlivek rozhraní 

programu, popisu ikon v prostředí aplikace, možnosti nastavení, vysvětlení nejen tvorby, 

editace, nabídky růžicového menu, či přehledný vyčet klávesových zkratek, ale i zároveň 

související použití slepých dat, retropologie nebo reference polygonového modelování. 

Praktická část bakalářské práce obsahuje webovou prezentaci zpracované nápovědy za pomoci 

typového jazyka HTML5 a PHP. Webová prezentace obsahuje zpracovanou teoretickou část 

přepracovanou do grafické podoby obohacenou o komentované videoukázky.  
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1 Polygonové modelování 

Polygony se skládají z geometrie založené na vrcholech, hranách a ploškách, které můžete 

použít k vytvoření trojrozměrných modelů v aplikaci Maya. 

Polygony jsou užitečné pro konstrukci mnoha typů 3D modelů a jsou široce používány při 

tvorbě 3D obsahu pro animované efekty ve filmu, interaktivních videohrách a na internetu. 

Terminologie polygonů 

Polygony (také mnohoúhelníky) jsou části roviny (3 nebo více stran), definované 

trojrozměrnými body (vrcholy) a úsečkami, které je spojují (hranami). Vnitřní oblast (výplň) 

polygonu se nazývá ploška.  Vrcholy, hrany a plošky jsou základními komponenty polygonů. 

Polygony se vybírají a upravují pomocí těchto základních komponent. 

Při modelování s polygony obvykle používáte trojstranné polygony nazývané triangles nebo 

čtyřstranné polygony nazývané quadrilaterals (quads). Maya také podporuje vytváření 

polygonů s více než čtyřmi stranami n-stěn (n-gons), ale nejsou tak běžně používané pro 

modelování. 

Jednotlivý polygon se běžně nazývá ploška a je definována jako oblast ohraničená třemi nebo 

více vrcholy a jejich přidruženými hranami. Když je mnoho plošek spojeno dohromady, vytvoří 

síť plošek, která se nazývá polygonová síť (polygon mesh –⁠ také označovaná jako polyset nebo 

polygonový objekt). 3D polygonové modely vytvoříte pomocí polygonových sítí. Polygonové 

sítě lze vytvořit pomocí různých technik. Více informací viz Přehled modelování polygonů.  

 

Obrázek 1 – Popis polygonu [7] 

Polygonové sítě normálně sdílejí vrcholy a hrany, které jsou společné mezi jednotlivými 

plochami. Jsou označovány jako sdílené vrcholy nebo sdílené hrany. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=3
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Síť polygonů může být také složena z několika nesouvislých sad spojených polygonů 

nazývaných pláště (shells). Vnější hrany sítě nebo skořápky se označují jako okrajové hrany. 

Polygonové modely mapované texturou 

Polygonové modely jsou mapovány texturou pomocí souřadnic UV textury. Více informací 

viz Mapping UVs. 

Zdroj [7] 

1.1 Přehled modelování polygonů 

Při vytváření 3D polygonových modelů v aplikaci Maya můžete použít celou řadu technik: 

• Primitivy jsou trojrozměrné geometrické tvary, které můžete vytvořit v aplikaci Maya. 

K dostupným primitivním tvarům patří koule, krychle, válec, kužel, plocha a mnoho dalších. 

Atributy základních primitiv můžete upravit tak, aby byly více či méně složité. Rovněž můžete 

pomocí různých nástrojů v sadě Modeling Toolkit rozdělit, vytáhnout, sloučit nebo odstranit 

různé komponenty na polygonové síti, abyste mohli upravit tvar primitiv. Mnoho 3D modelářů 

začíná s polygonovými primitivy jako s výchozím bodem pro své modely. Tato technika se 

označuje jako primitivní modelování. 

• Jednotlivé polygony lze vytvořit pomocí nástroje Create Polygon Tool nebo Quad Draw 

Tool. Oba tyto nástroje umožňují umístit jednotlivé vrcholy v pohledu scény a definovat tvar 

jednotlivých polygonů. Poté můžete tyto plochy dále rozdělit nebo vytáhnout a vytvořit tak 

polygonovou síť. Tato technika vytváření polygonů může být užitečná, pokud potřebujete, aby 

přesně odpovídala určitému tvaru nebo obrysu. Pokud potřebujete například modelovat 

konkrétní 3D logotyp pro animovanou sekvenci loga nebo sledovat obrys 2D rastrového 

obrázku importovaného do obrazové roviny (Image plane) jako referenci. 

• Polygony lze také vytvořit převedením existujících modelů NURBS nebo Subdivision 

surface pomocí funkce Convert, kterou najdete v nabídce Modify. 

Zdroj [7] 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-F5882F28-2430-4D17-9C30-77B0390727AE
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D4CD168A-34F2-465B-A39C-DE20B34E5535
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=31
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-20DEA0B6-C090-49EA-98AE-172F1C382A05
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-20DEA0B6-C090-49EA-98AE-172F1C382A05
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1.2 Polygonové normály 

Normála je teoretická čára kolmá na povrch polygonu. V aplikaci Maya se normály používají 

k určení orientace polygonové plošky (normály plošky – face normals) nebo toho, jak se hrany 

plošek vizuálně zobrazí ve vzájemném vztahu při stínování (vrcholové normály – vertex 

normals). 

 

Obrázek 2 – Ukázka polygonových normál [7] 

Normály plošek 

Přední strana polygonu je graficky znázorněna pomocí vektoru zvaného polygonová normála. 

 

Obrázek 3 – Grafické znázornění polygonové normály [7] 

Pořadí vrcholů kolem plošky určuje směr plošky (zda strana polygonu je přední nebo zadní). 

Pokud například umístíte vrcholy ve směru hodinových ručiček, bude normála plošky směřovat 

dolů. Pokud umístíte vrcholy proti směru hodinových ručiček, bude normála plošky směřovat 

nahoru. Viz Vytváření polygonů.  

To může být důležité, protože technicky jsou polygony viditelné pouze zepředu, ačkoli ve 

výchozím nastavení Maya automaticky vytvoří všechny polygony oboustranné, takže je můžete 

vidět i zezadu. Toto oboustranné chování můžete pro sítě vypnout. 

Když vystínujete nebo vykreslujete polygony, normály určují, jak se světlo odráží od povrchu,  

a vystínuje tyto výsledky. 

 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=31
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Normály vrcholu 

Normály vrcholů určují vizuální měkkost nebo tvrdost mezi plochami polygonu. Na rozdíl 

od ploškových normál nejsou polygonům vlastní, ale spíše reflektují, jak Maya vykresluje 

polygony v hladkém stínovaném (Smooth shaded) režimu. 

Normály vrcholu se objevují jako čáry vyčnívající z vrcholu, jedna pro každou plochu, která 

sdílí vrchol. 

• Když normály pro konkrétní vrchol směřují všechny stejným směrem (nazývané normály 

měkkých nebo sdílených vrcholů), dochází k hladkému přechodu hran mezi ploškami 

v hladkém stínovaném (Smooth shaded) režimu. 

 

Obrázek 4 – Vytvoření vyhlazeného vzhledu [7] 

• Když vrcholové normály směřují ve stejných směrech jako jejich plošky (nazývané normály 

tvrdých vrcholů), je přechod mezi ploškami tvrdý, což vytváří fazetový vzhled. 

 

Obrázek 5 – Vytvoření fazetového vzhledu [7] 

Manipulace s normály vrcholů je nejjednodušší způsob, jak změkčit (vyhladit) nebo vytvrdit 

(fazetovat) vzhled hran (creases – ostrost hran) bez použití další geometrie. To lze provést 

automaticky pomocí příkazu Soften / Harden Edge (Mesh Display > Soften Edge / Mesh 

Display > Harden Edge) nebo ručně manipulací s normály vrcholů pomocí nástroje Vertex 

Normal Edit Tool (Mesh Display > Vertex Normal Edit Tool). Když jsou vrcholové normály 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-2B0FD45A-6EE0-47BE-B243-3C802D38D9A7#GUID-2B0FD45A-6EE0-47BE-B243-3C802D38D9A7
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-2B0FD45A-6EE0-47BE-B243-3C802D38D9A7#GUID-2B0FD45A-6EE0-47BE-B243-3C802D38D9A7
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pro polygonovou síť ručně upravovány, zamknou se nebo zamrznou. Když odemknete dříve 

uzamčenou vrcholovou normálu, Maya automaticky přepočítá normálu vrcholu pro plošku na 

základě jeho výchozích výpočtů normál. 

Zdroj [7] 

1.3 Polygonové smyčky a prstence 

Komponenty smyček a prstenců vám umožňují vybrat několik komponent napříč sítě, 

aniž byste museli vybírat každou komponentu jednotlivě. 

Smyčky z hran 

Smyčka z hran je cesta z polygonových hran, které jsou spojeny v pořadí podle jejich 

společných vrcholů. Pokud například vyberete jednu vodorovnou hranu na kouli, smyčkový 

výběr vybere všechny vodorovné hrany podél stejné linie zeměpisné šířky na kouli. 

Viz Smyčkový výraz hran. 

 

Obrázek 6 – Smyčkový výběr hran [7] 

Můžete si vybrat: 

• Smyčku z hran, která úplně prochází polygonovou sítí. 

• Smyčku z hran, která částečně prochází polygonovou sítí. 

• Smyčky z hran na polygonové síti ve více směrech. 

Prstence z hran 

Prstenec z hran je cesta z polygonových hran, které jsou spojeny v pořadí podle jejich 

společných plošek. Pokud například vyberete jednu svislou hranu na kouli, prstencový výběr 

vybere všechny svislé hrany podél stejné linie zeměpisné šířky na kouli výběrem každé 

následné hrany, která sousedí s vybranou hranou. Viz Prstencový výběr hran. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=15
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=14
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Obrázek 7 – Prstencový výběr hran [7] 

Můžete si vybrat: 

• Prstenec z hran, který úplně prochází polygonovou sítí (uzavřený prstenec). 

• Prstenec z hran, který částečně prochází polygonovou sítí (otevřený prstenec). 

• Prstenec z hran na polygonové síti ve více směrech. 

Smyčky z plošek 

Smyčka z plošek je cesta z polygonových plošek, které jsou spojeny v pořadí podle jejich 

sdílených hran. Pokud například vyberete jednu plošku na kouli, smyčkový výběr vybere 

všechny plošky podél stejné linie zeměpisné šířky nebo délky na kouli výběrem každé následné 

plošky, která sousedí s vybranou ploškou. Viz Smyčkový výběr plošek. 

 

Obrázek 8 – Smyčkový výběr plošek [7] 

Můžete si vybrat: 

• Smyčka z plošek, která úplně prochází polygonovou sítí (uzavřená smyčka). 

• Smyčka z plošek, která částečně prochází polygonovou sítí (otevřená smyčka). 

Smyčky z vrcholů 

Smyčky z vrcholů je cesta z vrcholů, které jsou spojeny v pořadí podle jejich společných hran. 

Pokud například vyberete jeden vrchol na kouli, smyčkový výběr vybere všechny vrcholy podél 

stejné linie zeměpisné šířky nebo délky na kouli výběrem každého následujícího vrcholu, který 

sousedí s vybranou ploškou. Viz Smyčkový výběr vrcholů. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=12
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=13
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Obrázek 9 – Smyčkový výběr vrcholů [7] 

Můžete si vybrat: 

• Smyčka z vrcholů, která úplně prochází polygonovou sítí (uzavřená smyčka). 

• Smyčka z vrcholů, která částečně prochází polygonovou sítí (otevřená smyčka). 

Zdroj [7] [6] 

1.4 Variety polygonové geometrie (Two-manifold and non-manifold 

polygonal geometry) 

Polygonová geometrie může mít v aplikaci Maya různé konfigurace nebo typy topologie. 

Pochopení těchto charakteristik topologií může být užitečné, když potřebujete pochopit, proč 

se provedení operace při modelování nepodařila provést podle očekávání. 

Two-manifold topologie polygonu má síť, kterou lze rozdělit podél jejich různých hran 

a rozložit ji tak, aby se síť položila naplocho bez překrývajících se částí. 

Non-manifold topologie polygonu má konfiguraci, kterou nelze rozložit na souvislý plochý kus. 

Některé nástroje a akce v aplikaci Maya nemohou správně pracovat s non-manifold geometrií. 

Například starší Boolean algoritmus, funkce Reduce a Sculpting Tools nepracují s non-

manifold topologií polygonu. Obrázek níže ukazuje tři příklady non-manifold topologie 

polygonů. 

 

Obrázek 10 – Příklady non-manifold topologie polygonů [7] 

• V prvním příkladu (tvar „T“) sdílejí hranu více než dvě plochy. Toto je známé jako násobně 

připojená geometrie. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=81
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=151
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-246B90C9-914F-4EC6-8317-349AF2DE90F7
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• Ve druhém příkladu (tvar „motýlek“) dvě plochy sdílejí jeden vrchol, aniž by sdílely hranu. 

Tento tvar je také možný, pokud dva trojrozměrné tvary sdílejí vrchol (například dvě krychle, 

které se setkávají v jednom bodě). 

• Ve třetím příkladu má jeden tvar nesouvislé normály (bez okrajových hran). To znamená, 

že normála na každé ploše polygonu směřuje opačným směrem. Toto je méně zřejmý příklad 

non-manifold geometrie. 

Následující operace v aplikaci Maya mohou vytvářet non-manifold geometrii: 

• Vytažení plošek nebo hran pomocí Edit Mesh > Extrude. 

• Převrácení normál bez rozdělení geometrie Mesh Display > Reverse. 

• Sloučení vrcholů, hran nebo plošek do jednoho vrcholu Edit Mesh > Merge nebo Edit 

Mesh > Merge to Center. 

• Odstranění jedné nebo více plošek. 

Non-manifold topologii polygonů můžete převést na two-manifold topologii (včetně méně 

zřejmého případu sousedních ploch s opačnými normálami) pomocí Mesh > Cleanup. 

Chybná geometrie polygonu 

Některé typy polygonové geometrie nebudou v aplikaci Maya fungovat. Chybná geometrie 

zahrnuje vrcholy, které nejsou spojeny s polygonovou hranou a polygonovými hranami, takže 

nejsou součástí plošky (visící hrany). I když vám Maya neumožňuje vytvářet chybné typy 

geometrie, je možné tyto typy importovat z jiných softwarových aplikací. 

Zdroj [7] 

1.5 Planární a neplanární polygony 

Ploška polygonu je planární (rovinná), pokud: 

• všechny jeho vrcholy leží v určité rovině. Například trojúhelníková ploška je vždy rovinná, 

protože její tři body definují rovinu. 

Ploška polygonu je neplanární (nerovinná), když: 
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• má více než tři vrcholy a jeden nebo více těchto vrcholů neleží ve stejné rovině. Když je 

polygonová síť složena ze čtyřúhelníků (quads) nebo n-úhelníků (n-gons), můžou být plošky 

polygonu nerovinné.   

 

Obrázek 11 – Planární (Planar) a neplanární (Non-planar) ploška [7] 

Snažte se vytvářet rovinné polygonové plošky na polygonových sítích, kdykoli je to možné. 

Nerovinné polygonové plošky se v konečném vyobrazení nebo při exportu do interaktivní herní 

konzole mohou vykreslit nesprávně. Například na polygonové síti se mohou objevit vizuální 

stínované čáry nebo nežádoucí špice, kde byly rozděleny pro vykreslování, protože nejsou 

rovinné. 

Následující funkce vám mohou pomoci vyhnout se nerovinným polygonovým ploškám 

v polygonových sítích: 

• Při vytváření se vyhnete nerovinným polygonům, pokud použijete možnost nastavení Keep 

New Faces Planar při použití nástrojů Mesh Tools > Create Polygon [Tool] a Mesh Tools > 

Append to Polygon [Tool].  

• Opravit nerovinné plošky polygonů, můžete pomocí nástroje Multi-Cut Tool rozdělením 

na rovinné trojúhelníky (tris) nebo retopologizovat plochy, abyste lépe zvládli místo ohybu. 

 

Obrázek 12 – Opravení nerovinných ploch polygonů [7] 

• Vizuálně zkontrolovat nerovinné plošky polygonu můžete přizpůsobit zobrazení polygonů 

výběrem možnosti Display > Polygons > Non-planar Faces. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=243
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=240
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=240
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-93324AE7-5B19-4D74-B41B-74934B4AD20C
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1.6 Zobrazení polygonových komponent 

• Aplikace Maya ve výchozím zobrazení polygonových komponent používá různé barvy 

a velikosti, které vám pomohou identifikovat vybrané a nevybrané komponenty. 

Tabulka 1 – Zobrazení polygonových komponent [7] 

Komponenta Nevybráno Vybráno 

vrchol (Vertex) malý fialový čtvereček žlutý 

hrana (Edge) světle modrá světle oranžová 

okrajová hrana (Border 

edge) 

silnější čára   

ploška (Face) modrý bod ve středu světle oranžový odstín 

UV středně tmavý fialový čtvereček zářivě zelený 

Zdroj [7] 

1.7 Polygonové modelování v nabídkách růžicového menu 

K mnoha běžným nástrojům a příkazům polygonů můžete přistupovat prostřednictvím nabídek 

růžicového menu. To vám ušetří čas a zefektivní váš pracovní postup při modelování polygonů. 

Když ve scéně kliknete Shift + pravé tlačítko myši, zobrazí se nabídka různých položek podle 

toho, které komponenty jsou aktuálně vybrány: 

• Nic vybráno – nabídka růžicového menu zobrazuje možnosti vytvoření polygonu. 

• Vybraný polygonový objekt – nabídka růžicového menu zobrazuje nástroje a příkazy pro 

úpravu vybraného polygonového objektu. 

• Vybraná polygonová komponenta (vrchol, hrana nebo ploška) – nabídka růžicového menu 

zobrazuje nástroje a příkazy pro úpravy polygonu relevantní pro vybranou komponentu. 

Zdroj [7] 
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2 Výběr a tvorba polygonů 

2.1 Výběr polygonových komponent 

Pro provedení mnoha typů operací na polygonové síti musíte nejprve vybrat související 

polygonové komponenty, které chcete upravit.  

Následující tabulka popisuje techniky pro výběr různých typů polygonových komponent. 

Tabulka 2 – Výběr polygonových komponent [7] 

Na… Udělej tohle 

Výběr vrcholů 

polygonu 

Nastavte typ výběru na vrcholy: 

• Klikněte pravým tlačítkem myši na polygonovou síť a v nabídce vyberte 

možnost Vertex. 

nebo 

• Pokud je již vybrána polygonová síť nebo jiný typ komponent, můžete 

stisknutím klávesy F9 změnit typ výběru na vrcholy. 

Poté vyberte body, které se objeví na místě, kde se čáry protínají na polygonové síti. 

Výběr hran polygonu Nastavte typ výběru na hrany: 

• Klikněte pravým tlačítkem myši na polygonovou síť a v nabídce vyberte 

možnost Edge. 

nebo 

• Pokud je již vybrána polygonová síť nebo jiný typ komponent, můžete 

stisknutím klávesy F10 změnit typ výběru na hrany. 

Poté vyberte čáry na polygonové sítě. 

Výběr plošek 

polygonu 

Nastavte typ výběru na plošky: 

• Klikněte pravým tlačítkem myši na polygonovou síť a v nabídce vyberte 

možnost Face. 

nebo 

• Pokud je již vybrána polygonová síť nebo jiný typ komponent, můžete 

stisknutím klávesy F11 změnit typ výběru na plošky. 

Poté vyberte body ve středu plošek. 
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Na… Udělej tohle 

Výběr vrcholů, hran a 

plošek polygonu 

Nastavte typ výběru na více komponent (Multi): 

• Klikněte pravým tlačítkem myši na polygonovou síť a v nabídce vyberte 

možnost Multi. 

nebo 

• Pokud je již vybrána polygonová síť nebo jiný typ komponent, můžete 

stisknutím klávesy F7 změnit typ výběru na Multi. 

Poté vyberte komponenty na polygonové síti. 

Režim výběru pro více komponent (Multi) vybere vrcholy, hrany nebo plošky podle 

toho, co je nejblíže ke kurzoru myši. 

Výběr souřadnic UV 

textury pro 

polygonovou síť 

Nastavte typ výběru na UV: 

• Klikněte pravým tlačítkem myši na polygonovou síť a v nabídce vyberte 

možnost UV. 

nebo 

• Pokud je již vybrána polygonová síť nebo jiný typ komponent, můžete 

stisknutím klávesy F12 změnit typ výběru na UV. 

Poté vyberte body, které se objeví na místě, kde se čáry protínají na polygonové síti. 

I když si v zobrazení scény můžete vybrat UV, musíte použít UV Editor (UV > UV Editor), 

pokud chcete zobrazit rozložení UV pro polygonovou síť a provést další úpravy UV. 

Existující výběr polygonových komponent můžete změnit na jiný typ komponent. Například 

pokud máte aktuálně vybrané polygonové plošky, můžete výběr změnit tak, aby se místo toho 

vybraly vrcholy spojené s těmito ploškami. Viz Change one type of selection to another. 

Když vyberete příkaz Převod výběru (Select > Convert Selection > …), Maya automaticky 

převede výběr na zvolený typ komponent. Pokud Maya převede výběr z vrcholů (vertices) na 

hrany (To Edges) nebo na plošky (To Faces) nebo z hran (edges) na plošky (To Faces),  

převedený výběr obsahuje každou komponentu, která se dotkne původního výběru. Pokud 

například vyberete hranu (edge) a pokusíte se ji odstranit (Edit Mesh > Delete Edge/Vertex), 

Maya automaticky vybere hranu a odstraní ji. Pokud však tuto hranu převedete Select > 

Convert Selection > To Vertices, vyberete dva koncové vrcholy na hraně a pokusíte se je 

odstranit (Edit Mesh > Delete Edge/Vertex), Maya vybere všechny hrany, které se dotýkají 

obou vrcholů (stejně jako Select > Convert Selection > To Edges), a odstraníte je. Zdroj [7] 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-E6A6CDD4-5DDA-4306-9F83-2EDF83C9D4EB
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2.2 Výběr polygonových komponent pomocí Modeling Toolkit 

2.2.1 Výběr komponent pomocí výběrových režimů Modeling Toolkit 

Výběr komponentů pomocí výběrových režimů Modeling Toolkit  

1. Kliknutím na jednu z ikon režimu výběru v okně Modeling Toolkit nebo stisknutím 

klávesové zkratky aktivujte režim výběru. 

 

Obrázek 13 – Režimy výběru v Modeling Toolkit [7] 

2. Vyberte komponenty na síti. 

Když do výběru přidáte komponentu (Ctrl + Shift), bude zvýrazněna barvou. Když odeberete 

komponentu z výběru (Ctrl), bude ji vrácena původní barva. Barvy zvýraznění můžete nastavit 

v dialogovém okně Windows > Settings/Preferences > Color Settings. 

Zdroj [7] 

  

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D4CD168A-34F2-465B-A39C-DE20B34E5535
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2.2.2 Převod vybraných komponent na jiný komponentový typ 

Převedení vybraných komponent na jiný komponentový typ 

1. Vyberte skupinu komponent. 

2. V Modeling Toolkit klikněte za držení klávesy Ctrl na ikonu některého režimu výběru. 

Váš aktuální výběr se převede na jiný typ komponenty. V následujícím příkladu jsou vrcholy 

převedeny na plošky. 

 

Obrázek 14 – Převod vybraných komponent na jiný komponentový typ [7] 

Zdroj [7]  
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3 Úpravy polygonů 

Tato část obsahuje témata, která pokrývají širokou škálu technik pro práci s polygonovými 

ploškami, hranami, vrcholy, sítěmi, proxy, přehyby a normály pro úplnou kontrolu modelování. 

Zdroj [7] 

3.1 Úprava polygonových sítí 

3.1.1 Přidání polygonu k existující síti 

K existujícímu polygonové síti můžete přidat polygony pomocí nástroje Append to Polygon 

Tool. Nástroj Append to Polygon Tool vytvoří nový polygon pomocí hrany jako počátečního 

bodu. 

Přidání dalšího polygonu k existující síti 

1. Vyberte polygon, ke kterému připojíte další. 

2. Vyberte Mesh Tools > Append to Polygon Tool.  

3. Klikněte na okrajovou hranu, ke které se chcete připojit. 

Okrajové hrany se zvýrazní a vypadají silnější. 

Vybraná hrana je první hrana nové plošky. Šipky označují směr hrany. 

4. Kliknutím umístíte vrchol nového polygonu. Můžete také kliknout na jinou okrajovou hranu 

a použít ji v novém polygonu. 

Objeví se nový vrchol s čárou, která ho spojuje s posledním bodem na hraně vybrané plošky. 

5. Proveďte některou z následujících akcí: 

• Pokračujte v umisťování vrcholů nebo výběru hran. 

• Chcete-li odstranit poslední vrchol, který jste umístili, stiskněte klávesu Delete. 

• Chcete-li přepnout na úpravy vrcholů, stiskněte tlačítko Home nebo Insert. 

Na posledním vrcholu se objeví manipulátor. Pomocí manipulátoru přesouváte 

s vrcholem. Za držení levého tlačítka myši mimo manipulátor vrchol přesouváte 

interaktivně ve všech směrech bez ohledu vybraného směru na manipulátoru. Za držení 
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prostředního tlačítka myši mimo manipulátor vrchol přesouváte interaktivně ve směru 

vybraném na manipulátoru. Stisknutím tlačítka Home nebo Insert úpravy dokončíte. 

• Stisknutím klávesy Enter dokončíte tvorbu polygonu. 

• Stisknutím Y použijete poslední použitý nástroj (Append to Polygon Tool). 

Alternativně můžete také použít nástroj Quad Draw k dosažení podobného pracovního postupu. 

Viz Přidání polygonů pomocí Quad Draw. 

Zdroj [7] 

3.1.2 Zkosení hran a ploch polygonů 

Zkosení vytvoří na každé vybrané hraně novou plošku a zaoblení hrany polygonové sítě. 

Viz Bevel command. 

Zkosení hran nebo ploch 

1. Vyberte objekt nebo vyberte hrany nebo plošky, které chcete zkosit. 

Poznámka: Pokud vyberete objekt, Maya zkosí každou hranu v síti.   

2. V hlavní nabídce vyberte Edit Mesh > Bevel nebo klikněte  v panelu  

Modeling Toolkit. Maya zkosí vybrané hrany nebo obvodové hrany vybraných plošek. 

Poznámka: Přiřazení shaderu podle plošek je zachováno i po operaci zkosení. 

 

Obrázek 15 – Zkosení hrany a plošky [7] 

3. V zobrazeném okně editoru (In-View Editor) upravte atributy polyBevel. 

Zdroj [7] 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=190
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-40E124B1-36EA-4B85-823A-6CB2CD1BEFBE
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-C9C88AA3-CE61-4389-9A19-B6456427EBA2
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-40E32F44-1EB9-4DC6-8EE4-6A013EEC626F
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3.2 Transformace polygonových komponent 

Komponenty polygonu (vrcholy, hrany, plošky, UV) můžete transformovat pomocí panelu 

nástrojů (Tool Box) nástroji Posun (Move), Otočení (Rotation), Změna velikosti (Scale). 

Viz Transform Objects and Components. 

Při transformaci komponent existují různé metody, které mění způsob manipulace komponent. 

Tabulka 3 – Metody transformace polygonových komponent [7] 

Metoda Příklad: 

Společně: Transformujte všechny vybrané 

komponenty společně pomocí nástrojů Move, 

Rotate, or Scale. Viz Transform Objects and 

Components. 

 

Obrázek 16 – Metoda společně [7] 

Samostatně: Transformujte vybrané 

komponenty do menších skupin nebo jednotlivě 

pomocí místních referenčních rámců. Viz 

Transforming multiple components 

independently. 

 

Obrázek 17 – Metoda samostatně [7] 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-9622730D-3D21-451C-8BEE-E01BCC979F91
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-9622730D-3D21-451C-8BEE-E01BCC979F91
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-9622730D-3D21-451C-8BEE-E01BCC979F91
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-19EA6AD7-CC84-49DB-9E1A-47BA48E5DBFB
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-19EA6AD7-CC84-49DB-9E1A-47BA48E5DBFB
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Metoda Příklad: 

Posuvně: Posouvejte komponenty podél hran 

nebo povrchu. Viz Šoupnutí polygonových 

komponent podél jejich hran nebo Přesun 

polygonových komponent po povrchu. 

 

Obrázek 18 – Metoda posuvně [7] 

Podél vlastních vztažných bodů: Během 

transformace komponent můžete dočasně změnit 

vztažný bod a ovlivnit tak posun komponent. 

Viz Change the pivot point. 

 

Obrázek 19 - Metoda podél vlastních vztažných 

bodů [7] 

Přizpůsobivě: Transformujte komponenty tak, 

aby odpovídaly jinému povrchu polygonu. Viz 

Přizpůsobení vrcholů k povrchu. 

 

Obrázek 20 – Metoda přizpůsobivě [7] 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=70
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=70
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=71
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=71
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-150B390E-840B-4FE3-B8E9-8DEBCE7CEC97
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=72
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Metoda Příklad: 

Symetricky: Zrcadlená komponenta se 

transformuje podél osy symetrie. Viz 

Symetrické úpravy. 

 

Obrázek 21 – Metoda symetricky [7] 

Měkkým výběrem (Soft Select): Transformace 

komponent pomocí váhových úbytků (Falloff). 

Viz Přesun komponent s Falloff. 

 

Obrázek 22 – Metoda měkkým výběrem [7] 

Zdroj [7] 

  

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=156
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=73
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4 Obarvení polygonů 

4.1 Obarvení polygonů pomocí barvy na vrcholu 

Kromě přiřazení shaderů k polygonovým sítím můžete také přiřadit barvu ke každému vrcholu 

spojenému s polygonovou ploškou. Color per vertex (CPV) se běžně používají u 3D modelů, 

které jsou vytvořeny pro interaktivní videohry, aby účinněji simulovaly efekty stínování 

a efekty předsvícení. 

Color per vertex data lze přiřadit, i když je polygonový vrchol sdílen mezi ploškami, má barvu 

pro každou plošku, která je sdílí. Barvy ve vrcholech plošky se míchají dohromady napříč 

ploškami. 

Při uložení se Color per vertex data uloží samostatně do souboru scény. Můžete také použít 

jednu nebo více sad CPV dat nazývaných sady barev (color set) na polygonovou síť. 

Zdroj [7] 

4.2 Předsvícení (prelighting) polygonů 

Předsvícení ukládá data stínovaní a osvětlení z vykresleného vzhledu sítě do barvy na vrcholu 

(CPV) sítě. Předsvícení se také označuje jako „lehké zafixování“ (light baking), protože váže 

informaci k objektu. 

Objekty ve scéně můžete předsvítit pomocí funkcí Prelight, které používají softwarový 

vykreslovač Maya. 

Předsvícené objekty ve scéně umožňují jednoduššímu zobrazovacímu zařízení (například herní 

konzoli) zobrazovat objekty, jako by byly stínované a osvětlené, aniž by ve skutečnosti měly 

stínování, světla nebo textury a aniž by prováděly výpočty vykreslování v reálném čase. 

Po předsvícení scény ji můžete zjednodušit odstraněním světel a stínování nebo zjednodušit 

stínovací sítě, protože konečné stínované výsledky jsou použity (baked on) na polygony. 

Předsvícení je také užitečné při exportu na platformu, která nepodporuje určité efekty stínování. 

Například některá grafická rozhraní API podporují pouze omezený počet světel a mnoho 

platforem má k dispozici omezené množství paměti pro textury. Pokud předsvítíte některá 

světla a textury a použijete jejich efekty na geometrii, mohou být odstraněny ze scény. 



36 

 

 

Podobně některé platformy nemusí být schopny plně dosáhnout efektů dostupných ze sítě 

softwarového vykreslovače Maya. Předsvícení eliminuje potřebu přenosu funkce stínovací sítě. 

Úložiště vzorku (Sample storage) 

Vzorek lze uložit buď jako barva-na-vrchol-na-plošku, nebo může být použit k přemístění 

polohy vrcholu. 

Pokud je uložena jako barva-na-vrchol-na-plošku, je uložena barva RGB a alfa (průhlednost). 

Pro posunutí se změní souřadnice X, Y, Z polohy vrcholu. Protože vzorek obsahuje čtyři kanály 

(RGBA), posun používá hodnotu barvy jasu. 

Zdroj [7] 
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5 Slepá (blind) data 

Slepá data jsou informace uložené s polygony, které Maya žádným způsobem nepoužívá, 

ale jsou užitečné pro platformu, na kterou exportujete polygony, jako je interaktivní herní 

konzole. 

Například když použijete aplikaci Maya k vytváření obsahu pro interaktivní herní úrovně, 

můžete pomocí slepých dat určit, které plochy úrovně jsou „pevné“ nebo „prostupné“ pro 

postavu, nebo které plochy na polygonové síti jsou lávové a ubližují postavě, a tak dále. 

Pomocí Blind Data Editor můžete: 

• Definujte typy slepých dat, které potřebujete, a poté aplikujte slepá data na objekty nebo 

komponenty ve vaší scéně. 

• Vzneste dotaz ve své scéně na slepá data určitého typu nebo sady hodnot a pomocí nepravého 

zbarvení vizualizujte, jaká slepá data jsou přiřazena jednotlivým objektům. 

Poznámka: Můžete také použít slepá data na pláty (patches) NURBS pomocí „face“, ale 

nemůžete je zabarvit nepravým zbarvením. 

Šablony 

Šablona je seznam, který můžete vytvořit pro každou komponentu, ve které je uveden jeden 

nebo více atributů slepých dat a jejich datových typů. 

Pro atributy jsou možné datové typy: 

• int (celá čísla), 

• float/double (reálná čísla), 

• boolean (pravda/nepravda), 

• string (řetězec), 

• binary (surová data). 

Můžete určit, na které komponenty (plošky, vrcholy, hrany nebo všechny typy) se šablona 

použije. 

Každá šablona potřebuje jedinečné ID. Každý atribut potřebuje pro nastavení a načítání dat 

dlouhé i krátké názvy. 
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Když vytvoříte šablonu, můžete také vytvořit jednu nebo více předvoleb, které načtou 

předdefinované hodnoty do atributů. 

Zdroj [7] 

5.1 Nastavení struktury slepých dat 

Před přidáním slepých dat do polygonů musíte nastavit, jak budou informace strukturovány 

pomocí šablony. Šablona je seznam atributů a předvoleb. 

Definování nové šablony 

1. Zadejte příkaz MELu blindDataEditor v příkazovém řádku nebo okně Script Editor. 

Zobrazí se okno Blind Data Editor. 

2. Klikněte na kartu Type Editor. 

3. Klikněte na tlačítko New pod seznamem na levé straně. Možná budete muset změnit velikost 

okna, abyste ho viděli. 

4. Zadejte číslo ID, název šablony (Name template) a nastavte typ asociace (Association Type) 

na typ komponenty, se kterou je tato šablona přidružena (nebo jakoukoliv). 

5. Do šablony zadejte celý název (Long name), zkrácený název (Short name) a typ dat prvního 

atributu v šabloně. 

6. Pro jakékoliv další atributy, které chcete přidat, klikněte na tlačítko New Attr a přidejte další 

pole. 

7. Můžete definovat předvolby, které načtou předdefinované hodnoty do každého atributu. 

U všech předvoleb, které chcete vytvořit, klikněte na tlačítko New Preset. Zadejte název 

předvolby (Preset Name) a hodnotu pro každý atribut. 

8. Klikněte na tlačítko Save pod seznamem na levé straně. 

Poznámka: Pokud zadáváte nový typ slepých dat v Blind Data Editor a dáte uložit (Save), nový 

typ se neuloží (a nezobrazí se žádná chybová zpráva, která by naznačovala, že typ je nějakým 

způsobem neplatný, například duplicitní id), vyberte existující typ, stiskněte uložit (Save), 

proveďte znovu New a zadejte nový typ. Editor mohl být zmaten neúplnou úpravou provedenou 

dříve. 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A#GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A
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Úprava existující šablony 

1. Zadejte příkaz MELu blindDataEditor v příkazovém řádku nebo okně Script Editor. 

Zobrazí se okno Blind Data Editor. 

2. Klikněte na kartu Type Editor. 

3. V seznamu vlevo klikněte na název šablony. 

4. Upravte pole a změňte název šablony (Name template), typ asociace (Association type) 

a uvolněnou sadu (Free Set). Můžete také upravovat a přidávat nové předvolby. 

Můžete uložit šablonu do souboru šablon. To je užitečné, pokud chcete použít stejnou šablonu 

ve více scénách. 

Export šablony do souboru 

1. Zadejte příkaz MELu blindDataEditor v příkazovém řádku nebo okně Script Editor. 

Zobrazí se okno Blind Data Editor. 

2. Klikněte na kartu Type Editor. 

3. Klikněte na tlačítko Export pod seznamem na levé straně. 

Můžete uložit šablonu do textového souboru. To je užitečné, pokud chcete: 

• Převést informace o šabloně na jinou formu, jako je struktura programu. 

• Zobrazit šablonu ostatním lidem, jako jsou návrháři úrovní. 

Export šablony do textového souboru 

1. Zadejte příkaz MELu blindDataEditor v příkazovém řádku nebo okně Script Editor. 

Zobrazí se okno Blind Data Editor. 

2. Klikněte na kartu Type Editor. 

3. Klikněte na tlačítko Text Dump pod seznamem na levé straně. 

Zdroj [7] 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A#GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A#GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A#GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A
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5.2 Aplikování slepých dat na komponenty 

1. Vyberte komponenty. 

2. Zadejte příkaz MELu blindDataEditor v příkazovém řádku nebo okně Script Editor. 

Zobrazí se okno Blind Data Editor. 

3. Klikněte na kartu Apply. 

4. Vyberte šablonu ze seznamu vlevo. 

5. Zadejte hodnoty pro každý atribut nebo klikněte na přepínač předvoleb. 

6. Proveďte jednu z těchto věcí: 

• Kliknutím na tlačítko Apply v dolní části okna použijete hodnotu slepých dat na všechny 

komponenty. 

• Kliknutím na tlačítko Paint Values použijete nástroj Edit > Paint Selection Tool 

k aplikování hodnoty slepých dat na komponenty jejich namalováním. 

Zdroj [7] 

  

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A#GUID-1CE3727A-4F37-4551-B55B-DF8A43BD406A
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6 Retopologie 

Retopologie umožňuje vytvořit novou topologii založenou na vlastnostech referenčního 

povrchu. Sada nástrojů aplikace Maya pro retopologii nabízí zefektivnění nástrojů pracovních 

postupů (workflow), které umožňuje modelářům soustředit se na tvůrčí proces namísto 

hranových postupů (edgeflow) a polygonových počtů. 

Nástroj Quad Draw vám poskytuje úplnou kontrolu nad procesem retopologie a poskytuje 

nástroje pro rychlé vytvoření nové topologie a její upřesnění za běhu. 

Zdroj [7] 

6.1 Ruční vytváření nebo retopologie sítě pomocí Quad Draw 

Nástroj Quad Draw umožňuje vytvářet nové sítě, které jsou vázány na jiný objekt nebo rovinu. 

Quad Draw můžete použít k: 

 

Obrázek 23 – Použití nástroje Quad Draw [7] 

Kromě vytváření nových polygonů lze nástroj Quad Draw také použít k upřesnění 

existujících polygonových sítí. To zahrnuje: 

• Přidávání nových čtverců. 

• Přidání nových hranových smyček. 

• Změna rozložení existujících komponent. 

• Vyplňování otvorů. 

Zdroj [7] 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=190
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=191
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=192
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=193
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6.2 Automatická retopologie polygonové sítě 

Pokud máte síť, která je tvarována podle vašich představ, ale má špatnou topologii 

(nerovnoměrné plošky, n-gony atd.), můžete pomocí příkazů Remesh a Retopologize opravit 

celou síť a vyhnout se usilovnému ručnímu modelování. Tuto metodu použijte, pokud chcete 

rovnoměrně retopologizovat celou síť najednou. 

Každý z těchto příkazů lze také spustit samostatně, i když se obvykle spouštějí postupně. 

 

Obrázek 24 – Oprava celé sítě pomocí příkazů Remesh a Retopologize [7] 

Retopologizace sítě 

Poznámka: Pokud soubor scény obsahuje uzel polyRetopo před verzí Maya 2020, měli byste 

před provedením následujících kroků odstranit historii sítě. 

1. Vyberte síť. 

2. Přejděte do sady nabídek (menu set) Modeling. 

3. Příprava sítě pro retopologii. 

4. Vyberte Mesh > Retopologize >  . 

• Pokud chcete zachovat původní síť jako zálohu, povolte možnost Keep Original. 

• Pokud chcete zachovat označení tvrdých hran (hard edges) na retopologizovaném modelu,   

povolte možnost Preserve Hard Edges. 

• Pro organické povrchy: Výchozí nastavení je ideální pro organické povrchy. 

• Pro tvrdé povrchy: Nastavte vysoké hodnoty Topology regularity a Face uniformity (tj. 1) 

s nízkou hodnotou Anisotropy (tj. 0). 

Tím se převedou všechny plochy sítě na 4stranné plošky (quads). 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=211
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=212
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=198
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Poznámka: Tato operace může trvat dlouho, pokud pracujete s velmi hustou sítí. Průběh 

retopologizace si můžete prohlédnout v okně Output window. Chcete-li operaci zrušit, podržte 

klávesu Esc před dokončením retopologizace. 

5.  (Volitelné) Můžete upravit nastavení v uzlu polyRetopo a upravit tak výslednou síť. Každá 

změna, kterou provedete u atributu, však způsobí, že se algoritmus znovu spustí, pokud nejprve 

nezapnete přepínač Pause v uzlu. Důrazně doporučujeme tuto možnost zapnout, provést několik 

změn a poté jej vypnout, aby se všechny tyto změny projevily najednou. 

6. (Doporučené) Jakmile topologie vypadá dobře, důrazně doporučujeme okamžitě odstranit 

historii objektu (Edit > Delete by Type > History). 

Poznámka: Ignorování tohoto kroku bude pravděpodobně mít za následek opětovné spuštění 

polyRetopo po dalších operacích se sítí nebo při opětovném otevření souboru, což může trvat 

dlouhou dobu pro husté sítě. 

7.  (Volitelné) Přenesení UV z původní sítě na retopologizovanou síť vyberte původní síť, 

pak retopologizovanou síť a přejděte na Mesh > Transfer Attributes. 

Zdroj [7] 
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7 Reference polygonového modelování 

7.1 Sada nabídek (menu set) Modeling 

7.1.1 Nabídka Mesh 

Combine 

Booleans 

Booleovské operace vám umožní kombinovat polygonové sítě a vytvořit tak nový tvar. Operace 

počítají s průnikem, sdíleným objemem dvou sítí, aby vytvořily booleovský výsledek. 

Sjednocení (Union) 

Sloučí objem vybraných sítí. Původní dva objekty jsou zachovány s odstraněním sítě v průniku. 

Vyberte Mesh > Booleans > Union pro nastavení možností Možnosti Booleans Union. 

Rozdíl (Difference) 

Odečte objem (objemy) druhé vybrané sítě od první. 

Vyberte Mesh > Booleans > Difference pro nastavení možností Možnosti Booleans Difference. 

Poznámka: Z první vybrané sítě můžete extrahovat více sítí v operaci Difference. 

Průnik (Intersection) 

Zanechává pouze společný objem obou sítí v průniku. 

Vyberte Mesh > Booleans > Intersection pro nastavení možností Možnosti Booleans 

Intersection. 

Combine 

Sloučí vybrané sítě do jedné polygonové sítě. Mnoho úprav polygonu lze provádět jedině mezi 

dvěma oddělenými plášti sítě, jakmile jsou sloučeny do stejné sítě. 

Vyberte Mesh > Combine >  pro nastavení možností Možnosti Combine. 

Poznámka: Použijte Mesh > Combine s vypnutou konstrukční historií (Construction History), 

abyste mohli vymazat historii mnohokrát skinovaných položek do jediné sítě s čistým skinem.  

(Stále můžete používat Mesh > Combine se zapnutou konstrukční historií). 

 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=203
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=204
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=205
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=205
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=206


45 

 

 

Separate 

Rozděluje oddělené pláště sítě na samostatné sítě. Můžete oddělit všechny pláště najednou nebo 

můžete určit pláště, které chcete oddělit tak, že nejprve vyberete některé plošky na plášti, které 

chcete oddělit, než vyberete Mesh > Separate. 

Remesh 

Conform 

Vrcholy jednoho objektu uchytí na povrch jiného objektu. Viz Přizpůsobení vrcholů k povrchu. 

Vyberte Mesh > Conform >  pro nastavení možností Conform. 

Fill Hole 

Funkce vyplnění otvoru umožňuje vyplnit oblast polygonové sítě, kde polygony neexistují, 

pokud je oblast ohraničena třemi nebo více hranami polygonu. Výplň vytvoří polygon se třemi 

nebo více stranami pro vyplnění vybrané oblasti. 

Reduce 

Snižuje počet polygonů ve vybrané oblasti polygonové sítě, přičemž volitelně zohledňuje UV 

a barvy vrcholů při výběru oblastí, které se mají redukovat. Redukce je užitečná, pokud 

potřebujete snížit počet polygonů v určité oblasti polygonové sítě. Redukce polygonu je řízena 

pomocí vytvořeného uzlu polyReduce. To vám umožní experimentovat s množstvím redukce 

a lze ji zcela odstranit, pokud byste chtěli vrátit polygonovou síť do původního stavu před 

redukcí. Můžete také zachovat původní polohy vrcholu, aby se minimalizovala celková změna 

tvaru, ke které dochází v důsledku redukce na síti. Volitelně můžete namalovat množství 

polygonové redukce pomocí nástroje Mesh Tools > Paint Reduce Weights Tool. 

Vyberte Mesh > Reduce >  pro nastavení možností Reduce Options. 

Smooth 

Vyhladí vybranou polygonovou síť přidáním dělení (divisions) na polygony sítě. 

Vyberte Mesh > Smooth >  pro nastavení možností Smooth Options. 

Triangulate 

Převede existující výběr polygonu na trojúhelníky. 

Vyberte Mesh > Triangulate 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=72
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=207
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=208
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=209
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Quadrangulate 

Převede existující výběr polygonu na čtyřúhelníky. 

Vyberte Mesh > Quadrangulate >  pro nastavení možností Quadrangulate Options. 

Remesh 

Předefinuje topologii sítě nebo vybraných komponent rozdělením netrojúhelníkových ploch na 

trojúhelníky. Použijte Remesh k vytvoření rovnoměrně teselace (tessellated) trojúhelníkové sítě 

nebo přidejte detaily do určitých oblastí povrchu. 

Vyberte Mesh > Remesh >  pro nastavení možností Remesh Options. 

Retopologize 

Vytváří čistou novou topologii, která zachovává povrchové vlastnosti vybrané sítě a zároveň 

zajišťuje, aby všechny plošky byly čtyřúhelníky (quads). Chcete-li operaci zrušit, podržte před 

dokončením klávesu Esc. 

Poznámka: Pro dosažení nejlepších výsledků zkuste Remesh na geometrii před provedením 

Retopologize. Pokud soubor scény obsahuje uzel polyRetopo před verzí Maya 2020, měli byste 

smazat historii sítě před provedením další retopologizace. 

Vyberte Mesh > Retopologize >  pro nastavení  možností Retopologize Options. 

Mirror 

Mirror 

Zrcadlí vybraný objekt podél osy symetrie.  

Vyberte Mesh > Mirror >  pro nastavení možností Mirror options. 

Symmetrize 

Pokud je povolena topologická (topology) symetrie, zkopíruje Symmetrize vybranou topologii 

sítě přes osu symetrie. Viz Symetrizace asymetrických komponent. 

Transfer 

Clipboard Actions  

Copy Attributes 

Umožňuje kopírovat atributy UV, shadery a barvy na vrcholu z jedné polygonové sítě do druhé 

zkopírováním atributů do dočasné schránky. Funkci kopírování můžete nastavit tak, 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=210
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=211
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=212
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=213
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=160
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aby kopírovala jeden atribut nebo všechny tři současně. Možnosti atributů, které můžete 

kopírovat mezi polygonovými sítěmi, jsou popsány níže. 

Vyberte Mesh > Clipboard Actions > Copy Attributes >  pro nastavení možností Copy 

Attributes Options. 

Paste Attributes 

Umožňuje vložit všechny atributy UV, shadery a barvy na vrcholu, které jste dříve zkopírovali 

do dočasné schránky z jiné polygonové sítě. Funkci vložení můžete nastavit tak, aby vložila 

jeden atribut nebo kterýkoli ze tří atributů, které byly zkopírovány v důsledku operace 

kopírování. 

Clear Clipboard 

Clear Clipboard vyprázdní schránku všech uložených atributů polygonu, takže nové atributy 

lze následně zkopírovat a vložit mezi polygonové sítě. 

Použijte Mesh > Clipboard Actions > Clear Clipboard  >  a určete, které atributy (UV, 

Shader a Barva na vrchol) vymažete, když vyberete tuto položku nabídky. 

Transfer Attributes 

Transfer Attributes přenáší UV, Barvu na vrchol (CPV) a informaci o poloze vrcholu mezi 

sítěmi, které mají různé topologie (to znamená, že sítě mají různé tvary, vrcholy a odlišné 

hrany). 

Navíc přenášejí data vrcholu vzorkováním informací o vrcholu na zdrojové síti a poté přenáší 

informace do určené cílové sítě na základě srovnání, které je založeno na prostoru. V důsledku 

toho dojde k úpravě cílové sítě. 

Vyberte Mesh > Transfer Attributes >  pro nastavení možností Transfer Attributes Options. 

Transfer Shading Sets 

Nástroj Transfer Shading Sets umožňuje přenášet data přiřazení stínování mezi dva objekty, 

které se mohou topologicky lišit. Například můžete přenášet data přiřazení stínování z krychle 

na kouli. Plochám na podobných místech jsou přiřazena stejná data stínování. 

Vyberte Mesh > Transfer Shading Sets >  pro nastavení  možností Transfer Shading Sets 

Options. 

 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=214
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Transfer Vertex Order 

Nástroj Transfer Vertex Order umožňuje převést pořadí ID vrcholů z jednoho objektu na druhý. 

Viz Úprava nebo přemístění pořadí vrcholů. 

Optimize 

Cleanup 

Provádí různé operace s výběrem k identifikaci a odstranění nepodstatné a neplatné geometrie 

polygonu. 

Vyberte Mesh > Cleanup >  pro nastavení možností Cleanup Options. 

Smooth proxy 

Subdiv Proxy 

Subdiv Proxy vyhladí vybranou polygonovou síť přidáním polygonů a zachová původní 

nevyhlazenou síť jako zástupce (proxy). Mezi proxy a vyhlazenou verzí sítě se vytvoří uzlové 

spojení, takže změny tvaru nebo topologie proxy aktualizují vyhlazenou verzi sítě. Subdiv 

Proxy je užitečný pro přetvoření a  nebo animaci hrubší verze polygonového modelu (s menším 

počtem komponent, o které se nemusíte starat) a zatímco uvidíte, jak bude vyhlazená verze 

vypadat. 

Zvolte Mesh > Smooth Proxy > Subdiv Proxy >  pro nastavení možností Subdiv Proxy 

Options. 

Remove Subdiv Proxy Mirror 

Odstraní vyhlazenou síť vytvořenou pomocí Mesh > Smooth Proxy > Subdiv Proxy 

(s možností Mirror Behavior nastavenou na Full) a zkombinuje dvě poloviny proxy sítě 

(původní a zrcadlenou síť) do jediné sítě (podobně jako u zrcadlení Mesh > Mirror geometrie 

na původní síti). Úpravy provedené na jedné polovině sítě již nebudou automaticky zrcadleny 

na druhou polovinu. Poté, co jste vytvořili symetrický model pomocí Mesh > Smooth Proxy 

> Subdiv Proxy (s možností Mirror Behavior nastavenou na Full), použijte Subdiv Proxy 

Mirror k odstranění vyhlazené sítě. Poté použijte Mesh > Smooth Proxy > Subdiv Proxy 

(s možností Mirror Behavior nastaveným na None) k vytvoření vyhlazené sítě, kterou můžete 

animovat nesymetricky. 

Vyberte Mesh > Smooth Proxy > Remove Subdiv Proxy Mirror  >  pro nastavení  možností 

Remove Subdiv Proxy Mirror Options. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=64
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Crease Tool 

Nástroj Crease Tool existuje na dvou místech Mesh > Smooth Proxy > Crease Tool a Mesh 

Tools > Crease Tool. Viz Přehyb polygonových hran a vrcholů. 

Toggle Proxy Display 

Přepíná zobrazení subdiv proxy objektu mezi normálním polygonovým zobrazením 

a vyhlazenou verzí subdiv proxy. Přepínání mezi subdiv proxy a normálním polygonovým 

režimem zobrazení je užitečné při modelování polygonových povrchů, chcete-li se rychle 

přepínat mezi oběma režimy, abyste zobrazili náhled vaší práce. Mezi těmito režimy zobrazení 

můžete také přepínat pomocí klávesové zkratky Ctrl + '. 

Both Proxy and Subdiv Display 

Zobrazuje současně síť proxy a subdiv síť. Tento režim zobrazení můžete také ovládat pomocí 

klávesové zkratky ~. 

Zdroj [7] 

7.1.2 Nabídka Edit Mesh 

Najdete v sadě nabídek Modeling. 

Components 

Add Divisions 

Rozdělí vybrané polygonové komponenty (hrany nebo plošky) na menší komponenty. Přidat 

dělení (Divisions) je užitečné, když potřebujete přidat podrobnosti k existující polygonové síti 

buď globálním, nebo lokálním způsobem. Plošky polygonu lze rozdělit na trojstranné 

(trojúhelníky) nebo čtyřstranné (čtyřúhelníky). Hrany lze rozdělit tak, aby se zvýšil počet stran 

na plošce. 

Vyberte Edit Mesh > Add Divisions >  pro nastavení  možností Add Divisions Options. 

Poznámka: Obsah okna Add Divisions Options se mění v závislosti na tom, v jakém režimu 

výběru komponent se právě nacházíte. 

 

 

 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=52
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Bevel 

Vytváří úkosy na polygonech podél aktuálně vybraných hran nebo plošek. Viz Bevel command 

a Zkosení hran a ploch polygonů. 

Vyberte Edit Mesh > Bevel >  pro nastavení možností Bevel Options. 

Bridge 

Vytvoří přemostění polygonové sítě (přidáním dalších plošek) mezi vybranými dvojicemi 

okrajových hran na existující polygonové síti. Výsledná přemosťující polygonová síť 

je sloučena s původní polygonovou sítí a hrany jsou spojeny. Viz Bridge Command a Bridge 

between border edges. 

Vyberte Edit Mesh > Bridge >  pro nastavení možností Bridge Options. 

Circularize 

Vytváří kruhové tvary komponent. 

 

Obrázek 25 – Vytváření kruhových tvarů kmponent [7] 

 

Vyberte Edit Mesh > Circularize >  pro nastavení možností Circularize Options. 

Merge to Center (Collapse) 

Kolaps hran podle jednotlivých komponent poté sloučí přidružené vrcholy pro každou 

zkolabovanou hranu zvlášť. Kolaps funguje také na ploškách, ale při použití hran vytváří 

výsledky, které jsou předvídatelnější. Pokud chcete kolaps a sloučení vybraných plošek, měli 

byste nejprve vybrat Edit Mesh > Merge to Center. 

Connect 

Když jsou vybrány vrcholy anebo hrany, Connect je spojí přes hrany. Vrcholy jsou spojeny 

přímo se spojovacími hranami, zatímco hrany jsou spojeny v jejich středu. 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-40E124B1-36EA-4B85-823A-6CB2CD1BEFBE
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=50
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=229
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Vyberte Edit Mesh > Connect >  pro nastavení  možností Connect Components Options. 

Detach 

Když jsou vybrány vrcholy, Detach oddělí vybrané vrcholy sdílené více ploškami do několika 

vrcholů v závislosti na počtu plošek, které vrchol sdílí. Hrany plošek spojených s vrcholem 

se v důsledku toho také nesdílejí. Když jsou vybrány plošky, Detach oddělí výběr plošek podél 

jeho okrajových hran. Když jsou vybrány hrany, Detach oddělí vybrané hrany na dvě 

překrývající se hrany. Pokud provedete operaci Detach přes cestu hran, budou vrcholy podél 

této cesty také odděleny podél této cesty. Vrcholy na koncích každého výběru zůstávají 

připojené k oběma novým hranám nebo cestám hran. Pokud jsou vybrány vrcholy i hrany, 

výchozí nastavení Detach má stejné chování, jako když jsou vybrány pouze vrcholy. 

 

Obrázek 26 – Použití Detach na hranách [7] 

Poznámka: Detach ignoruje všechny vrcholy, které nejsou sdíleny. 

Extrude 

Vytáhne nové polygony z existujících plošek, hran nebo vrcholů, s možnostmi transformovat 

a přetvarovat nové polygony při jejich vytažení z výběru. Viz příkaz Extrude. 

Vyberte Edit Mesh > Extrude >  pro nastavení možností Extrude Options. 

Poznámka: Nastavení Keep Faces Together lze zapnout a vypnout při použití nástroje Extrude 

pomocí kláves Ctrl + Shift + kliknutí pravým tlačítkem myši na objekt, kdykoli se zobrazí 

manipulátor (Show Manipulator Tool) a výběrem volby Toggle Keep Faces Together. 

Merge 

Sloučí vybrané hrany a vrcholy, které jsou ve specifikované prahové vzdálenosti od sebe. 

Například dvě vybrané hrany budou sloučeny do jedné sdílené hrany. 

Vyberte Edit Mesh > Merge >  pro nastavení možností Merge Components Options. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=222
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Merge to Centre 

Sloučí vybrané vrcholy do jednoho a sloučí také všechny přidružené plošky a hrany. Výsledný 

sdílený vrchol je umístěn ve středu původního výběru. 

Poznámka: Merge to Center sloučí do středového bodu na základě výběru. Pokud chcete 

kolaps hran podle komponenty, vyberte hrany, poté vyberte Edit Mesh > Collapse, nebo zvolte 

Merge/Collapse Edges > Collapse Edge z růžicové nabídky. (Chcete-li otevřít růžicové menu 

pomocí kláves, zvolte Shift + klik pravým tlačítkem myši na hranu.) 

Transform 

Transform umožňuje posun, otáčení nebo změnu měřítka polygonových komponent (hrany, 

vrcholy, plošky a UV) vzhledem k normále při vytváření uzlu historie. 

Vyberte Edit Mesh > Transform >  pro nastavení možností Transform Components Options. 

Flip 

Zamění polohu vybraných komponent se zrcadlenými protějšky přes osu symetrie. 

Viz Symetrizace asymetrických komponent. 

Symmetrize 

Přesune komponenty do zrcadlené polohy odpovídajících komponent přes osu symetrie. 

Viz Symetrizace asymetrických komponent. 

Vertex 

Average Vertices 

Vyhlazení polygonové sítě posunutím poloh vrcholů. Na rozdíl Mesh > Smooth příkaz 

Average Vertices nezvýší počet polygonů v síti.  

Vyberte Edit Mesh > Average Vertices >  pro nastavení možností Average Vertices Options. 

Chamfer Vertices 

Nahrazuje vrchol rovinnou polygonovou ploškou. 

Vyberte Edit Mesh > Chamfer vertices >  pro nastavení možností Chamfer Vertices 

Options. 
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Reorder Vertices 

Umožňuje změnit pořadí ID vrcholů na polygonovém objektu. Viz Úprava nebo přemístění 

pořadí vrcholů. 

Edge 

Delete Edge/Vertex 

Odstraní očividné hrany nebo vrcholy z polygonové sítě v závislosti na tom, které komponenty 

jsou vybrány. Když jsou vybrány vrcholy, odstraní všechny sdílené vrcholy vybrané na síti. 

Výsledkem je také odstranění sdílených hran spojených s vybranými vrcholy. Plošky 

obklopující smazané vrcholy a hrany jsou nahrazeny jediným n-stranným polygonem 

vytvořeným z vrcholů obklopujících smazaný vrchol. Když jsou vybrány hrany, odstraní 

všechny sdílené hrany, které jsou vybrány na síti, stejně jako všechny sdílené vrcholy, které 

jsou spojeny s odstraněnými hranami. Odstranění komponent neodstraní okrajové hrany 

na polygonové síti. 

Tip: Můžete také rychle stisknout Ctrl + Delete nebo Ctrl + Backspace a vymazat rychle 

komponenty. 

Edit Edge Flow 

Umožňuje změnit stávající hrany tak, aby respektovaly kontinuitu zakřivení. 

Vyberte Edit Mesh > Edit Edge Flow >  pro nastavení možností Edit Edge Flow Options. 

Flip Triangle Edge 

Přepíná hranu polygonu rozdělující dva trojúhelníkové polygony tak, že je spojuje mezi jejich 

protilehlými rohy. 

Poznámka: Pokud je polygon v režimu hran (Edge), můžete z růžicového menu Shift + 

kliknutím pravým tlačítkem myši zvolit Flip/Spin Edge. 

Spin Edge Backward 

Vybrané hrany otočí proti směru vinutí a najednou změní jejich připojení. 

Poznámka: Pokud je polygon v režimu hran (Edge), můžete z růžicového menu Shift + 

kliknutím pravým tlačítkem myši zvolit Flip/Spin Edge. 

Spin Edge Forward 

Vybrané hrany otočí ve směru vinutí a najednou změní jejich připojení. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=64
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=64
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=231
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Hrany musí být připojeny pouze ke dvěma ploškám, aby mohly být otočeny. 

Pokud hranu několikrát zatočíte, Maya upraví atribut Offset existujícího uzlu historie. Otočení 

hran neovlivní ID vrcholů nebo ID hran, avšak při otočení hrany se sousední plošky otáčí spolu 

s ní. 

Face 

Assign Invisible Faces 

Přepíná vybrané plošky jako neviditelné. Plošky přiřazené jako neviditelné se ve scéně 

neobjeví. Tyto plošky však stále existují a lze s nimi stále manipulovat. 

Vyberte Edit Mesh > Assign Invisible Faces >  pro nastavení možností Assign Invisible 

Faces Options. 

Duplicate 

Vytvoří novou samostatnou kopii všech vybraných plošek. Duplikované plošky se stanou 

součástí původní sítě, které jinak zůstanou nedotčeny. 

Vyberte Edit Mesh > Duplicate >  pro nastavení možností Duplicate Options. 

Extract 

Oddělí vybrané plošky od sdružené sítě. Vyjmuté plošky se stanou samostatným opláštěním 

uvnitř existující sítě. Pokud vyberete v objektovém režimu oddělenou síť, bude vybrána síť 

se všemi vyjmutými ploškami. 

Vyberte Edit Mesh > Extract >  pro nastavení možností Extract Options. 

Poke 

Rozdělí vybrané plošky a umožní vám zatlačit nebo vytáhnout střed původního polygonu. 

Například čtyřstranný polygon (quad) je rozdělen na 4 trojstranné polygony s jedním sdíleným 

vrcholem uprostřed. Po operaci Poke se objeví manipulátor, který vám umožní dále 

transformovat vrchol. 

Vyberte Edit Mesh > Poke >  pro nastavení možností Poke Options. 

Wedge 

Vytáhne oblouk nových polygonů (klínového tvaru) z existujících plošek. 

 Vyberte Edit Mesh > Wedge >  pro nastavení možností Wedge Options. 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=232
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=232
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=233
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=234
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=235
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=236
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Curve 

Project Curve on Mesh 

Promítne křivku na polygonový povrch. 

Vyberte Edit Mesh > Project Curve on Mesh >  pro nastavení možností Project Curve on 

Mesh Options. 

Split Mesh with Projected Curve 

Rozdělí nebo rozdělí a oddělí hrany na povrchu polygonu. 

Vyberte Edit Mesh > Split Mesh with Projected Curve >  pro nastavení možností Split 

Mesh with Projected Curve Options. 

Zdroj [7] 

7.2 Polygonové uzly (Polygon Nodes) 

7.2.1 blendColorSets 

Uzel blendColorSets se vytvoří vždy, když sloučíte nebo smícháte dvě sady barev. K tomuto 

uzlu lze přistupovat z panelu Channel Box nebo Attribute Editor. 

Style Blend 

Nastavuje typ prolnutí použité pro kombinování vybraných barevných sad. 

Alpha Blend 

Viz Over. 

Multiply 

Viz Multiply. 

Add 

Viz Add. 

Subtract 

Viz Subtract. 

 

http://polygonovemodelovani.jednoduse.cz/?co=detail&id=237
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=237
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=238
http://polygonovemodelovani.jednoduse.cz/?co=detail&id=238
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-67A8E4EC-D22E-4696-9617-EDFE3475B540
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-3C0CCD4F-ADC3-47A5-ACF7-9A43C4AE1B67
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-423F5D80-DD26-42E1-A07C-58A54810A6D5
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-C162BE81-0A82-41A2-879D-8C4CCF1CDFF9
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Linear Blend 

Viz Linear. 

Bilinear Blend 

Viz Bilinear. 

Color Channel 

Viz Channels. 

Primary (Red) Weight 

Nastaví hodnotu primární váhy pro vybranou míchanou sadu barev. U LinearBlend se nastavuje 

pouze hodnota váhy sady míchaných barev. U BilinearBlend se nastavuje hodnota zdrojové 

váhy sady míchaných barev. U ColorChannel se nastavuje váha červeného kanálu (Red channel 

weight) sady míchaných barev. 

Secondary (Green) Weight 

Nastaví hodnotu sekundární váhy pro vybranou míchanou sadu barev. U BilinearBlend 

se nastavuje hodnota základní váhy sady míchaných barev. U ColorChannel se nastavuje váha 

zeleného kanálu (Green channel weight) sady míchaných barev. 

Blue Weight 

Nastaví váhu modrého kanálu pro vybraný styl ColorChannel sady míchaných barev. 

Alfa Weight 

Nastaví hodnotu váhy alfa kanálu pro vybranou sadu míchaných barev. 

Base Color Set 

Sekundární sada barev vybraná na podílu při míchání. 

Blend Color Set 

První sada barev vybraná na podílu při míchání. 

Destination Color Set 

Název míchané sady barev. 

 

 

http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-89AC4BFF-0CBD-42D9-A4BE-ACD56276005D
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-234595B0-F5A6-43A9-8356-E7185E35E923
http://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D#GUID-D66DA4E9-57C9-46D8-9D9E-9BDA453E455D__GUID-107682F1-BCF6-45C7-8CDD-0141DDE28ECF
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Swap Base and Blend Sets 

Zamění zdrojovou barvu (Blend Color Set) a základní barvu (Base Color Set) pro vybranou 

sadu míchaných barev. Swap Base and Blend Sets mohou změnit výsledky prolnutí v závislosti 

na vašem aktuálním režimu prolnutí. 

Zdroj [7] 

7.2.2 polyAppend 

Tyto další atributy jsou specifické pro uzel polyAppend a lze je upravovat v panelu Attribute 

Editor. 

Subdivision 

Mění počet dělení, které jsou rozloženy podél hran připojovaného polygonu. Výchozí hodnota 

je 1. 

Vertices 

Tyto hodnoty představují polohu vrcholů, které jste umístili při připojení k polygonu. Pokud 

jste například umístili tři vrcholy (například v panelu Attribute Editor), zobrazí se pouze tři sady 

hodnot. Změňte tyto hodnoty, pokud chcete přesunout vrcholy a změnit tvar připojeného 

polygonu. 

Zdroj [7] 
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8 Zpracování webové prezentace 

Vzhledem k obrovskému rozsahu zpracovávané práce, která ve výsledku obsahuje více než 

100 000 slov odborného překladu z anglického jazyka a pochopitelné nemožnosti obsáhnout 

celou práci v rámci tištěné teoretické části bakalářské práce, byla nejen pro účel prezentace 

práce ale i za účelem přehledné a snadné dostupnosti zpracované části nápovědy vypracována 

webová prezentace jako nosič obsahující plný text práce. 

Samotná webová prezentace vychází ze struktury a vzhledu originální webové nápovědy 

aplikace Autodesk Maya 2020 a jak je naprosto patrné, zcela úmyslně se ji snaží po grafické 

stránce co nejvíce napodobit. Díky tomu je možná jednoduchá a rychlá orientace uživatele mezi 

originální nápovědou a českou lokalizací obsáhlou v této práci. Obsahově se práce zaměřuje 

pouze na lokalizaci sekce polygonového modelování a jejích podkapitol. Ostatní části originální 

nápovědy jsou nebo případně mohou být zpracovány v jiných bakalářských pracích. 

Tato bakalářská práce je již v pořadí třetí částí zabývající se lokalizací originální nápovědy 

aplikace Autodesk Maya. Proto bere v úvahu i již existující zpracované bakalářské práce.  

Vzhledem k budoucím plánům sloučení všech těchto částí do jedné přehledné nápovědy, jejímž 

nosičem bude také webová prezentace, je zároveň brán ohled na co největší grafickou 

podobnost pro jednoduchou orientaci uživatele, který prozatím využívá více těchto webových 

prezentací.  

 

Obrázek 27 – Ukázka úvodní stránky webové prezentace 

Webová prezentace byla vytvořena za pomocí nástrojů PhpStorm, XAMPP, Notepad++ 

a databáze MySQL.  

Pro vytvoření webové prezentace bylo použito skriptovacího jazyka PHP, značkovacího 

jazyka HTML5 společně s kaskádovými styly CSS, dotazovacího jazyka SQL 

a programovacího jazyka JavaScript. 

Zdroj [7] [8] 
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8.1. Struktura webové prezentace 

Vzhledem k velkému množství obzvláště obrazového materiálu bylo potřeba vytvořit 

hierarchický systém adresářů, v nichž se nachází potřebné soubory webové prezentace. Byly 

použity čtyři adresáře a výchozí stránka index.php. 

 

Obrázek 28 – Adresářová struktura webové prezentace 

V adresáři „class“ se nachází soubor „Database.php“ zajištující fungování samotné 

databáze. Adresář css obsahuje soubor „style.css“ obsahující definici grafického vzhledu 

webové prezentace a soubor „reset.css“, který slouží k resetu nastavení webového prohlížeče. 

Adresář „img“ slouží pro uchování obrazových materiálů především názorných obrázků ve 

formátu JPG, PNG a animovaných obrázků GIF. Pro velké množství materiálů obsažených 

v tomto adresáři byla vytvořena struktura adresářů ve formátu „číslo kapitoly.číslo 

podkapitoly“ odpovídající číslování kapitol. 

 

Obrázek 29 – Adresáře s obrazovými materiály webové prezentace 

Stejným postupem byly pojmenovány samotné obrázky navíc doplněné o pořadové číslo 

obrázku v tématu. Tedy „číslo kapitoly.číslo podkapitoly_pořadové číslo“. 
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Obrázek 30 – Struktura obrázků v souborovém systému 

Adresář „include“ obsahuje webové stránky „domu.php“ a „detail.php“ první zmíněná 

stránka obsahuje uvítání uživatele na webu a menu s výběrem témat, druhá pak z databáze na 

základě výběru z menu uživatelem načítá z databáze příslušný obsah vybraného tématu zapsaný 

v podobě HTML5 a zobrazuje jej v pravé části webové prezentace.  

Zdroj [7] [8] 

8.2. Značkovací jazyk HTML5 

HTML neboli „Hypertext Markup Language“ je značkovací jazyk používaný při vytváření 

obsahu webových stránek. Jeho pomocí specifikujeme, která část textu bude nadpisem, 

odstavcem, nebo zda bude nějaká část textu sloužit jako odkaz vedoucí například na jinou 

webovou stránku a podobně.  

Tyto značky se označují jako tagy. Například „<h1>Nadpis</h1>“ webový prohlížeč vypíše 

text mezi tagy <h1> a </h1> jako nadpis. Obdobně mezi <p> a </p> jako odstavec. 

Na následujícím obrázku je například zobrazeno jedno z témat nápovědy v jazyce HTML. 

 

Obrázek 31 – Ukázka tématu zpracovaném v HTML jazyce. 
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Výsledná prezentace tohoto kódu pak ve webovém prohlížeči vypadá následovně. 

 

Obrázek 32 – Ukázka tématu zpracovaném v HTML ve webovém prohlížeči. 

Zdroj [8] [10] 

8.3. Kaskádové styly CSS 

CSS neboli „Cascading Style Sheet“ je značkovací jazyk, který slouží k popisu, jak má 

prohlížeč zobrazovat vzhled obsahu různých HTML tagů. Jeden CSS soubor může využívat 

více HTML stránek, díky tomu je možné jednoduše a přehledně zobrazovat jednotně například 

nadpisy, či odstavce na celé webové prezentaci najednou. Stejně tak v případě nutnosti změny 

není třeba měnit nastavení ve všech HTML souborech, ale pouze v jediném CSS souboru, 

což značně zjednodušuje a zpřehledňuje práci při vytváření grafické úpravy webové prezentace.  

Následující fragment kódu ukazuje část CSS kódu webové prezentace, který upravuje vzhled 

těla celé stránky a hlavičky webu. 
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Obrázek 33 – Ukázka CSS hlavičky webové prezentace. 

Zdroj [8] [10] 

8.4. PHP 

PHP neboli (Hypertext Preprocessor) je skriptovací jazyk s otevřeným zdrojovým kódem, 

který funguje na serveru webu. Používá se k například k dynamické změně obsahu stránky, 

prací s databází nebo soubory. Do PHP souborů mohou být vloženy HTML, CSS, JavaScript 

kódy. 

V této práci je jazyk PHP použit k načítání obsahu dat z databáze MySQL, kdy za pomocí 

jednoduchého dotazu pomocí jazyka SQL, doplněného o id tématu získaného metodou GET 

je z databáze načteno a zobrazeno příslušné téma. 

 

Obrázek 34 – Načítání tématu z databáze 

To je pak za pomocí dalšího PHP příkazu echo vypsáno na obrazovku webového prohlížeče. 

 

Obrázek 35 – Výpis tématu z databáze za pomocí jazyka PHP. 

Zdroj [8] [11] 
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8.5. JavaScript 

JavaScript je programovací jazyk používaný pro programování způsobu chování webových 

stránek.  

V této webové prezentaci je JavaScript použit pro zvýrazňování témat z menu, které 

odpovídá aktuálnímu zobrazovanému tématu pro lepší orientaci v menu. Do stránky je vložena 

knihovna jQuery a vytvořen cyklus, pokud se URL adresa shoduje s odkazem, tak se odkazu 

přiřazuje příslušný styl z CSS. 

Zdroj [8]  

8.6. MySQL 

Jednou s nepoužívanější databází ve spojení s PHP pro použití na webových stránkách je 

databázový systém MySQL. S užitím jazyka PHP se můžete připojit k databázi. Data v databázi 

MySQL jsou uložena v tabulkách. Tabulka je soubor souvisejících dat a skládá se ze sloupců 

a řádků. MySQL používá standardní dotazovací jazyk SQL. SQL dotaz je požadavek na 

databázi. Můžeme se dotazovat databáze na konkrétní informace a nechat vrátit sadu záznamů.  

Například na následujícím obrázku se „tážeme“ databáze pomocí příkazu „SELECT * 

FROM temata WHERE id_tematu = :id_tem“, na téma uložené pod ID webové stránky, na 

které se uživatel odkazuje a zpět získáváme data z databáze, které obsahuje téma 

odpovídajícímu ID z odkazu webové stránky.  

 

Obrázek 36 – Načítání tématu z databáze 

Zdroj [8] [12] [11] 
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Závěr 

Hlavním obsahem celé bakalářské práce je lokalizace originální anglické nápovědy pro 

aplikaci Autodesk Maya 2020. Lokalizace vznikla pro potřeby výukové činnosti v reakci na 

neexistující oficiální českou lokalizaci nápovědy k aplikaci Autodesk Maya 2020. Originální 

lokalizace nápovědy je totiž dostupná pouze v těchto jazycích: angličtina, mandarínština 

a japonština. Zároveň je i velmi omezena možnost české odborné literatury zabývající se oblastí 

polygonového modelování a aplikací Maya jako takovou, jejíž nabídka je pro potřeby studia 

a získávání znalostí nedostačující. 

Bakalářská práce ovšem nemá za účel poskytnout kompletní překlad celé nápovědy aplikace 

Maya, jejíž rozsah mimořádně převyšuje možnosti zpracování celé nápovědy v jediné 

bakalářské práci. Obsahově se tedy práce zaměřuje pouze na lokalizaci oblasti polygonového 

modelování a podkapitol, a i tak dosahuje úctyhodného objemu zpracovaného odborného textu 

anglického jazyka. Ostatní části originální nápovědy jsou nebo případně mohou být zpracovány 

v jiných bakalářských pracích. 

Vzhledem k obrovskému rozsahu zpracovávané práce, která ve výsledku obsahuje více než 

100 000 slov odborného překladu z anglického jazyka, je pochopitelně nemožné obsáhnout 

celou práci v rámci tištěné teoretické části bakalářské práce, proto byla nejen pro účel 

prezentace práce, ale i za účelem přehledné a snadné dostupnosti zpracované části nápovědy 

vypracována webová prezentace jako nosič obsahující plný text práce. 

Během zpracování lokalizace nápovědy bylo nutné čelit mnoha chybám a nesrovnalostem 

originální nápovědy v rozporu se skutečným chováním aplikace Autodesk Maya 2020. Při 

řešení těchto nesrovnalostí bylo třeba velmi opatrně balancovat mezi tím, zda se bude 

v lokalizaci držet přesného překladu s tím, že se v české lokalizaci ponechají nesrovnalosti, 

chyby či dokonce „bláboly“ originální nápovědy, nebo se odchýlit od originální nápovědy 

a tyto nesrovnalosti opravit. 

Samotná webová prezentace vychází ze struktury a vzhledu originální webové nápovědy 

aplikace Maya 2020 a jak je naprosto patrné, zcela úmyslně se ji snaží po grafické stránce co 

nejvíce napodobit. Díky tomu je možná jednoduchá a rychlá orientace uživatele mezi originální 

nápovědou a českou lokalizací obsáhlou v této práci. Tato bakalářská práce je také již v pořadí 

třetí částí zabývající se lokalizací originální nápovědy aplikace Autodesk Maya. Proto bere 

v úvahu i již existující zpracované bakalářské práce, a to nejen pro přívětivé uživatelské 

rozhraní a grafickou podobnost mezi těmito webovými prezentacemi, ale i k budoucím plánům 

sloučení všech těchto částí do jedné nápovědy.  
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Webová prezentace je dostupná na adrese http://polygonovemodelovani.jednoduse.cz 

Zdroj [8]  

http://polygonovemodelovani.jednoduse.cz/
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PŘÍLOHY 

Příloha A – Tangenty a Binormálové vektory. 

 Příloha B – Slovník základních pojmů. 

 Příloha C – Praktická část práce na DVD.  
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PŘÍLOHA A – TANGENTY A BINORMÁLOVÉ VEKTORY 

Následuje stručné vysvětlení toho, jak se počítají tangenty a binormály vektorů pro 

polygonovou síťovou geometrii v aplikaci Maya. 

Pro výpočet tangenty trojúhelníku 

Vstupy: Pro každý vrchol trojúhelníku projdeme: v (poloha vrcholu, 3-float), n (poloha 

normály, 3-float), t (hodnota tex coord, 2 float): v[3][3], n[3][3] t[3][2]; 

Výstupy: Pro každý vrchol vypočítáme a vrátíme vektor tangenty (3-float): tangentArray[3][3]; 

 float $edge1[3]; 

 float $edge2[3]; 

 float $crossP[3]; 

 float $tangentArray[3][3]; 

 //============================================== 

 // x, s, t 

 // S & T vectors get used several times in this vector, 

 // but are only computed once. 

 //============================================== 

 $edge1[0] = $v[1][0] - $v[0][0]; 

 $edge1[1] = $t[1][0] - $t[0][0]; // s-vector - don't need to compute this 

multiple times 

 $edge1[2] = $t[1][1] - $t[0][1]; // t-vector 

 $edge2[0] = $v[2][0] - $v[0][0]; 

 $edge2[1] = $t[2][0] - $t[0][0]; // another s-vector 

 $edge2[2] = $t[2][1] - $t[0][1]; // another t-vector 

 $crossP = crossProduct( $edge1, $edge2 ) ; 

 normalize( $crossP ); 

 bool $degnerateUVTangentPlane = equivalent( $crossP[0], 0.0f ); 

 if (degnerateUVTangentPlane) 

 $crossP[0] = 1.0f; 

 float $tanX = -$crossP[1]/$crossP[0]; 
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 $tangentArray[0][0] = $tanX; 

 $tangentArray[1][0] = $tanX; 

 $tangentArray[2][0] = $tanX; 

 //-------------------------------------------------------- 

 // y, s, t 

 //-------------------------------------------------------- 

 $edge1[0] = $v[1][1] - $v[0][1]; 

 $edge2[0] = $v[2][1] - $v[0][1]; 

 $edge2[1] = $t[2][0] - $t[0][0]; 

 $edge2[2] = $t[2][1] - $t[0][1]; 

 $crossP = crossProduct( $edge1, $edge2 ); 

 normalize( $crossP ); 

 degnerateUVTangentPlane = equivalent( $crossP[0], 0.0f ); 

 if (degnerateUVTangentPlane) 

 $crossP[0] = 1.0f; 

 float $tanY = -$crossP[1]/$crossP[0]; 

 $tangentArray[0][1] = $tanY; 

 $tangentArray[1][1] = $tanY; 

 $tangentArray[2][1] = $tanY; 

 //------------------------------------------------------ 

 // z, s, t 

 //------------------------------------------------------ 

 $edge1[0] = $v[1][2] - $v[0][2]; 

 $edge2[0] = $v[2][2] - $v[0][2]; 

 $edge2[1] = $t[2][0] - $t[0][0]; 

 $edge2[2] = $t[2][1] - $t[0][1]; 

 $crossP = crossProduct( $edge1 , $edge2 ); 

 normalize( $crossP ); 

 degnerateUVTangentPlane = equivalent( $crossP[0], 0.0f ); 

 if (degnerateUVTangentPlane) 
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 $crossP[0] = 1.0f; 

 float $tanZ = -$crossP[1]/$crossP[0]; 

 $tangentArray[0][2] = $tanZ; 

 $tangentArray[1][2] = $tanZ; 

 $tangentArray[2][2] = $tanZ; 

 // Orthnonormalize to normal 

 for( int $i = 0; $i < 3; $i++) 

 { 

 $tangentArray[i] -= $n[i] * $tangentArray[i].dot( n[i]); 

 } 

 // Normalize tangents 

 normalize( $tangentArray[0] ); 

 normalize( $tangentArray[1] ); 

 normalize( $tangentArray[2] ); 

  

 return $tangentArray; 

Výpočet povrchové tangenty a binormály 

Výpočet tangenty je založen na souřadnicích textury (uv) dané použité sady souřadnic textury 

(uvset). Použité normály jsou geometrické normály, které počítají s vyhlazovacími 

a uživatelskými normálami. 

Pro každý trojúhelník na plošce se vypočítají tangenty pro každý vrchol trojúhelníku. Pokud je 

trojúhelník mapován (tj. má uv) a tyto uv jsou ne-degenerované, provede se výpočet v Per 

triangle tangent computation.  

Degenerované uv znamená, že vektor má 0 délku v uv prostoru podél libovolné hrany 

trojúhelníku. Pokud trojúhelník není namapován nebo degenerován, použijí se pro výpočet 

tangenty geometrické hrany. Pro každý vrchol (i) trojúhelníku se vypočítá takto: 

tangent[i] = vertex[i+1 % 3] - vertex[i]; 

tangent[i] = tangent[i] - normal[i] * dotProduct( tangent[i], normal[i]); 

normalize( tangent[i] ); 

https://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-71B1F48B-52C7-46D2-ADE8-F920AC0DD3F9#WS17956D7ADBC6E7367F9C4AAC117AE333A12-8000
https://help.autodesk.com/view/MAYAUL/2020/ENU/?guid=GUID-71B1F48B-52C7-46D2-ADE8-F920AC0DD3F9#WS17956D7ADBC6E7367F9C4AAC117AE333A12-8000
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Pro mapovanou plošku pro každý uvId na vrcholu uchováváme seznam sdílených tečen, 

a to pouze tehdy, je-li přidružený normalId pro tento vrchol stejný. 

Tak uvId je offset do uv sady datového pole, normalId je offset do normál datového pole. Pole 

tangenciálních dat bude odpovídat velikosti uvId datového pole. Každý seznam je 

normalizován pro výpočet konečného sdíleného tangenciálního vektoru. 

Binormály se vypočítají jako normalizovaný křížový součin tangent a normálových vektorů 

v daném vrcholu na plošce. Binormály jsou vypočítány a ukládány do mezipaměti na vyžádání. 
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PŘÍLOHA B: SLOVNÍK ZÁKLADNÍCH POJMŮ 

NURBS (Non-Uniform Rational B-Splines) objekty 

NURBS objekt obsahuje tyto atributy: 

• segmenty (spans) 

• sekce (section) 

• stupně (degree) 

Na NURBS objektu lze vybrat: 

• řídící vrchol (Control vertex) 

• obálka (Hull) 

• povrchový plát (Surface patch) 

• isočáry (Isoparm) 

• povrchový bod (Surface point) 

• povrchový UV (Surface UV) 

Polygonové objekty 

Polygonový objekt obsahuje tyto atributy: 

• dělení (Subdivision) 

Na polygonovém objektu lze vybrat: 

• hranu (Edge) 

• vrchol (Vertex) 

• vrchol plošky (Vertex face) 

• plošku (Face) 

• více (multi) ‑ hrany, vrcholy a plošky 

• UV (UV) 

Subdiv (subdivision surfaces) – dělené povrchy 

Subdiv aplikace Autodesk Maya už nepodporuje. Subdiv lze pouze načíst a převést do 

NURBS nebo polygonových objektů. 
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Ostatní důležité pojmy: 

• vztažný bod (pivot point) 

• poličky (Shelves) 

• panel nástrojů (Tool Box) 

• průhledový displej (HUD ‑ head-up display) 

• úrověn detailů (LOD ‑ Level Of Detail) 

• sady nabídek (Menu set) 

Zdroj [8] 

 


