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Bakalářská práce „Výuka modelování a animování v programu Blender3D“  se 
zaměřuje na práci se 3D scénovými objekty a animování v tomto programu. Výukový 
interaktivní kurz bude sloužit pro osvojení základních i pokročilejších znalostí v programu 
Blender. 
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1 Úvod 

Tématem mé bakalářské práce je „Výuka modelování a animování v programu 
Blender3D“. Práce je proto rozdělena na část teoretickou, kde si vysvětlíme jednotlivé 3D 
techniky, a na část praktickou, kde budou použity části teoretické bakalářské práce i 
s názornými příklady.  

V teoretické části se tedy seznámíme s programem Blender3D a jeho vývojem. 
Dále budeme seznámeni s prostředím programu. Ukážeme si, jak můžeme upravit 
uživatelské nastavení a zároveň jak se dá program ovládat. V dalších částech bakalářské 
práce se zaměříme na různé modelovací techniky a modifikace scénových objektů. 
Ukážeme si samozřejmě i práci s texturami, jejich tvorbu a jejich mapování na objekty. 
V další části probereme osvětlování scény, jak nejlépe osvítit scénu a jaké typy světel 
v Blenderu můžeme nalézt. Podrobněji si popíšeme vykreslování (rendering) a jeho 
nastavení. V následující kapitole se budeme zabývat animováním pomocí takzvaných klíčů 
a také pomocí IPO (IPO znamená Interpolation) editoru. V neposlední části si povíme o 
částicových systémech a efektech, jak můžeme simulovat různé objekty či látky. 
V závěrečné části si probereme něco málo o skriptech, které se v Blenderu využívají a jsou 
psány v jazyku Python. 

Praktická část mé bakalářské práce se bude zabývat problémem vytvoření 
webových stránek ve smyslu interaktivního kurzu výuky v programu Blender tak, aby byl 
srozumitelný pro začátečníky. Budou zde použity články z teoretické části, které budou 
doprovázeny názornými příklady k dané problematice. Lekce praktické části bakalářské 
práce budou vždy doplněny videoukázkami dané problematiky nebo doprovodnými 
soubory.   
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2 Blender a seznámení s jeho historií 

2.1 Co je program Blender?  

Blender je software, který slouží pro 3D modelování, animování, vytváření her, 
vykreslování a přehrávání. Patří mezi nejmladší programy pro 3D grafiku. Na jeho vývoji 
začala pracovat nizozemská společnost NeoGeo v roce 1995. Hlavním cílem a přáním 
firmy bylo vyvinout volně šiřitelný, modelovací a animační program. Program je dostupný 
pro velké množství operačních systému jako je Windows, Linux, Sun Solaris či Mac OS X, 
protože je založený na grafické knihovně OpenGL. Po tříletém vývoji vznikla z původní 
firmy nová s názvem Not a Number, která se pokusila v roce 2001 prosadit na trhu 
komerční verzi Blender Publisher. Po neúspěchu firma zkrachovala a od roku 2002 
program vyvíjí nezisková společnost Blender Foundation. Koncem roku 2002 získala firma 
Blender Foundation práva k původním verzím a Blender byl uvolněn jako tzv. open 
source, tedy jako program s volně přístupnými zdrojovými kódy. To znamenalo pro zběhlé 
uživatele programování velkou výhodu, a mohli si proto program zkompilovat sami. 

Důvodem proč je Blender tak výjimečný program, je právě již poznamenaná 
skutečnost, že je zcela zdarma. Z toho vyplývá, že se otevírá oblast pro začínající uživatele 
3D grafiky, aniž by museli investovat jakékoliv finanční prostředky. Další výhodou tohoto 
programu je jeho velikost a hardwarová nenáročnost. To znamená, že velikost instalačního 
souboru v aktuální verzi 2.49 je zhruba 11 MB a po instalaci nám tento program zabírá 
okolo 40 MB na disku. Když si vezmeme možnosti, kterými tento program disponuje, zdá 
se nám to až neuvěřitelné. Výkonnost a rychlost Blenderu závisí samozřejmě na 
parametrech počítače a nejdůležitější takovou komponentou je grafická karta. 

Doposud jsme se zmiňovali jen o výhodách, které Blender má. Uveďme si ale také 
nějakou nevýhodu, kterou je po spuštění zřejmě uživatelské prostředí. To se může pro 
běžného uživatele operačního systému Windows zdát příliš nepřehledné. Vezměme si 
příklad, kdy klávesová zkratka CTRL+X  nevyvolá vyjmutí,  jak je to u systému Windows, 
ale začne práci s novým souborem. Podobně je to třeba s funkční klávesou F1, která 
v systémech Windows standardně vyvolává nápovědu, v Blenderu se touto zkratkou 
otevírá nový soubor. Ale nebojme se toho, prostředí je tu vytvořeno dobře a tlačítka jsou 
umístěna přehledně. 

2.2 Vývoj Blenderu a jeho historie 

O historii Blenderu jsme si již něco málo pověděli. Zde se pokusíme stručně 
vysvětlit vývoj Blenderu, který započal verzí 2.0. Tato verze obsahovala velkou novinku a 
tou byl tzv. game engine. Po neúspěchu firmy Not a Number na trhu se od verze Blenderu 
2.26, která vyšla v roce 2003, podílejí na vývoji programátoři z celého světa. Z toho 
vyplývá, že četnost zveřejňování nových verzí je opravdu hojná a možnosti Blenderu se 
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stále zlepšují. V další části si lehce popíšeme vývoj jednotlivých verzí Blenderu. Ukážeme 
si jen některé verze, protože je jich opravdu hodně. Kdybychom byli více zvědaví, můžeme 
si o dalších verzích a jejich změnách přečíst na domovských internetových stránkách 
Blenderu (viz [2]).  

2.2.1 Verze 2.30  
Toto je první verze programu, která od verze 2.26 prodělala nejvíce změn. Bylo tu 

prezentováno vylepšené uživatelské prostředí. Dále přibyla možnost numerického zadávání 
souřadnic. Byla rozšířena funkce „zpět“, která si nyní dokáže zapamatovat více operací. 
Další nástroj, který potěšil uživatel, byl Knife tool, který dokáže vytvářet nové vertexy 
v hranách. Jelikož se v této verzi vyskytlo mnoho chyb, byly v následující verzi 2.31 
opraveny [2]. 

2.2.2 Verze 2.35 
V této verzi je asi nejdůležitější novinkou tzv. Outliner. Outliner je diagram 

zobrazující data ve scéně Blenderu v hierarchickém uspořádání. Narozdíl od staršího(stále 
dostupného) OOPS schematic zde můžete jednotlivé objekty ve scéně vybrat a používat tak 
Outliner k zpřehlednění práce se složitějšími scénami. Dále je to vylepšení tlačítka „zpět“, 
které se dá již použít i v objektovém režimu (dříve se dalo použít jen v režimu editačním). 
Také se dají v editačním režimu vybírat i hrany a plochy (dříve bylo možné vybírat jen 
vertexy) [4]. 

2.2.3 Verze 2.40 
Tato verze přináší velké množství novinek a vylepšení. Jednou z nich jsou nové a 

vylepšené nástroje pro animaci. Jsou tu i nové nástroje pro simulace animací fyzikálních 
jevů, jako jsou například pohyby tekutin. Dále se dostalo i na vylepšení rozhraní pro efekty 
s částicemi, pod čímž si uživatel může představit srst nebo vlasy. Byly upraveny nástroje 
pro rozdělování a booleovská operace průnik a mnoho dalších [2]. 

2.2.4 Verze 2.45 
V této verzi nepřibyly žádné významné novinky, vývojáři se raději zaměřili na 

opravy a vylepšení. Jako opravy bychom mohli uvést částicové systémy při aplikaci stínů, 
dále byla odstraněna chyba, která nastala v případě, kdy výsledkem průniku dvou těles byl 
prázdný mesh objekt [1]. 

2.2.5 Verze 2.49  
V poslední verzi, která je aktuálně stabilní, byla vylepšena podpora game engine, 

který nyní podporuje vícenásobná videa textur pro interaktivní přehrávání. Další vylepšení 
získal i Node editor, který se používá pro tvorbu a úpravu materiálových vlastností a textur. 
Nyní v něm můžeme vytvářet moderní procedurální textury. Malba v 3D pohledu byla 
vylepšena na podporu projekce obrazu, která nám nyní umožní malovat přímo na náš 
model, aniž bychom se museli starat o UV mapování nebo švy [2]. Dále následuje mnoho 
dalších vylepšení.  
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3 Základní seznámení 

3.1 Seznámení s prost ředím 

Na začátek bychom si měli povědět něco o uživatelské komunikaci s Blenderem. 
S programem komunikujeme prostřednictvím myši a klávesnice, což je jedno 
z nejzákladnějších pravidel mezi začátečníky. Jednou rukou ovládáme myš a druhou 
klávesnici. Blender pak s námi komunikuje přes různá okna na obrazovce počítače. 

V této době je Blender  pro českou lokalizaci téměř dokončen, ale můžeme se 
v ojedinělých případech setkat s případy, že vše přeloženo není. Proto jsou všechny 
obrázky a popisy v mé bakalářské práci psány v angličtině, abychom předešli mystifikaci. 

Další neméně důležitou věcí je pro nás rozložení znaků na klávesnici. Jak si 
postupně ukážeme, mnoho příkazů se dá vyvolat jednou klávesou či kombinací kláves. 
Toto se pokusíme osvojit, jelikož je to daleko efektivnější než hledání příkazů v nabídkách. 
Měli bychom myslet i na rozložení české a anglické klávesnice. My, jakožto programátoři 
a grafici, bychom měli preferovat rozložení anglické, což je vhodné i pro práci 
s Blenderem. 

Příkazy se v Blenderu mohou zadávat pomocí textových nabídek nebo 
prostřednictvím různých tlačítek či polí. Velkým zmatením by pro nás  mohlo být zadávání 
číselných údajů do numerických tlačítek. Zde existují celkem tři možnosti, jak tyto údaje 
zadávat. Prvním a nejpřesnějším způsobem je klepnutí levým tlačítkem myši na tlačítko při 
stisknuté klávese Shift. Tímto se dostaneme do editačního režimu tlačítka, ve kterém už 
můžeme zadat námi požadovanou hodnotu z klávesnice. Dalším způsobem je, že klikneme 
na levou či pravou stranu tlačítka. Jestliže klikneme na levou stranu, hodnota se snižuje, 
kliknutím na pravou stranu se naopak hodnota zvyšuje. Třetím způsobem je rychlá změna 
hodnoty o řádově vyšší. Provedeme ji tak, že klepneme do požadovaného pole a se stále 
stlačeným levým tlačítkem myši se posouváme doprava či doleva podle toho, zda chceme 
hodnotu zvyšovat či snižovat. 

Teď bychom se už mohli seznámit s prvním spuštěním programu a s tím, co zde 
uvidíme. Po spuštění programu se nám zobrazí tři okna. První tzv. User Preference, které 
uživatelům Blenderu umožňuje provádět uživatelská nastavení pro zpříjemnění jejich 
práce. Dalším oknem je okno grafické tzv. 3D View. Toto okno nás bude zajímat nejvíce, 
protože v něm se modelují scénové objekty. V tomto okně se po startu nacházejí čtyři 
objekty, a to 3D kurzor, který určuje, kam ve scéně se umístí nový objekt, dále je to 
krychle, světelný zdroj a kamera, která představuje pozorovatele a určuje směr pohledu. 
Jak můžeme vidět na obrázku 1, kde je vše popsáno. Posledním a nejspodnějším oknem je 
textové, tzv. Buttons Window, které je v celém Blenderu nejdůležitější a nejpoužívanější. 
Seskupuje mnoho nejrůznějších příkazů pro práci se scénovými objekty. Tyto příkazy jsou 
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shrnuty do šesti nabídek, které se dají vyvolat ikonami a některé i klávesami. V dalších 
kapitolách se k těmto nabídkám ještě vrátíme a popíšeme je podrobněji. 

 

Obrázek 1 − Vzhled Blenderu po prvním spuštění 

V Blenderu platí pravidlo, že okna se nemohou překrývat. Můžeme je však 
zvětšovat tak, že kurzorem myši najedeme na hranice mezi okny, a kurzor se nám 
změní na dvojitou šipku. Když v tomto okamžiku stiskneme levé tlačítko myši a 
začneme s myší pohybovat, uvidíme, že se velikost okna mění, ale na úkor 
sousedního okna. 

3.2 Práce s okny a jejich typy 

V minulé kapitole jsme zmínili první tři základní druhy oken. Pro začátek bychom 
se měli pozastavit nad skutečností, že některá okna, která nejsou zobrazena do maximální 
velikosti, nezobrazují všechny části. Proto bychom měli pracovat s nejvyšším rozlišením, 
které náš počítač dokáže zvládnout.  

V Blenderu ve verzi 2.49 máme celkem šestnáct typů oken, jak můžeme vidět na 
obrázku 2. Pojďme si tu stručně představit nejdůležitější z nich a popsat, k čemu slouží. Tři 
již zmíněná okna, která se nám objeví po startu, patří mezi nejdůležitější. Jsou to User 
Preference, 3D View a Buttons Windows. Dále tu máme File Browser a Image Browser. 
Jak už z jejich názvu vyplývá, okna slouží k prohlížení souborů a obrázků. Node Editor, 
který slouží pro práci s materiály. Outliner, o kterém jsme se už zmínili (viz kapitola 
2.2.2). Dále následuje Text Editor, ve kterém se vytváří Python skripty. Dále je tu pak 
Video Sequence Editor, který dokáže spravovat animace a tudíž přidávat vylepšující 



15 
 

efekty. UV/Image Editor k aplikování textur. A na závěr tu máme Ipo Curve Editor a 
Action Editor, které nám slouží pro animace. 

 

Obrázek 2 − Rozbalovací nabídka k volbě okna 

V předchozím odstavci jsme se zmínili o přepínání oken, které jsou na scéně 
celkem tři. Teď si ukážeme, že na obrazovce můžeme mít libovolný počet oken, ale každé 
okno zabere místo na úkor ostatních. Pojďme si ukázat příklad, kde si okno 3D View 
rozdělíme na další dvě. První věc, kterou uděláme, je, že najedeme kurzorem myši na horní 
hranici mezi okny User Preferences a 3D VieW. Zobrazí se nám tu dvojitá šipka, jako 
bychom chtěli okno zvětšovat či zmenšovat. My ale v tuto chvíli stiskneme pravé tlačítko 
myši a zobrazí se nám rozbalovací nabídka s volbami, které můžeme vidět na obrázku 3. 
Vybereme si Split Area a objeví se nám svislá čára, kterou si umístíme do pozice, kde 
chceme, aby se nám okno rozdělilo. Teď vidíme, že z jednoho okna nám vznikly dvě. 

 

Obrázek 3 – Rozbalovací nabídka pro rozdělení okna 

Stejným způsobem budeme pokračovat. Kurzorem myši najedeme na novou hranici 
a tentokrát vytvoříme vodorovnou čáru. Konečný výsledek můžeme vidět na obrázku 4, 
kde jsme si pravé okno změnili na Outliner, ve kterém vidíme všechny objekty na scéně. 
Druhé vytvořené okno jsme změnili na UV/Image Editor. 

Teď si ještě ukážeme postup inverzní. Pokud bychom měli mnoho oken, můžeme 
snížit jejich počet. Snižování oken se provádí stejným způsobem jako rozdělování. 
Klepneme pravým tlačítkem myši na hranici dvou oken a z rozbalovací nabídky vybereme 
Join Areas. Poté už jen klepneme na to okno, které chceme odstranit. 
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Obrázek 4 – Rozdělení okna 3D View 

V Blenderu ale již máme možnost si vybrat z předem vytvořených obrazovek. 
Nabídku nalezneme na panelu User Preference, což vidíme na obrázku 5. Všimněme si že, 
jsou tu možnosti, které slouží vždy pro specifický typ úkonu. Například pro animování 
nebo pro skriptování. Je tu i možnost si volbou ADD NEW vytvořit svou vlastní obrazovku, 
kdyby nám nevyhovovaly ty, které se tu nachází. Pokud bychom chtěli vytvořenou 
obrazovku smazat, stačí jen u vybrané obrazovky zmáčknout křížek, který se nachází 
vpravo rozbalovací nabídky. Zkusme chvíli experimentovat s přepínáním obrazovek a 
pozorovat, jak se okna dělí. 

 

Obrázek 5 – Nabídka obrazovek 

 

3.3 Uživatelské nastavení 

Stejně jako v jiných 3D modelovacích programech, se dá i v Blenderu upravovat 
nastavení pro zlepšení práce jeho uživatelů. Provádí se tak, že v okně User Preferences si 
myší najedeme na jeho hranici a zvětšíme ji na výšku posunutím jeho hranice. Poté se nám 
objeví celkem sedm tlačítek, které předtím vidět nebyly. Na obrázku 6 vidíme, které z nich 
to jsou. 
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Obrázek 6 – Uživatelské nastavení 

První možností, kterou vidíme, je panel View & Controls. V této sekci se nacházejí 
nejrůznější uživatelská nastavení pro práci v Blenderu. Můžeme si zde například nastavit 
možnost, která nám umožní rozbalení rolovací nabídky bez nutnosti na její kliknutí. Tato 
možnost se zde nazývá Open on Mouse Over. Je tu i možnost View Name, která nám 
v okně 3D View zobrazuje, v jakém jsme pohledu. Dále je tu invertování kolečka myši 
pomocí tlačítka Invert Zoom, které nám obrací směr kolečka. Zajímavý je i Rotation Angle, 
což je úhel, který nám určuje, po jakých řádových jednotkách nám bude rotovat těleso. 
Možností je mnoho, proto doporučuji, abychom si je odzkoušeli ze své vlastní iniciativy, 
díky čemuž uvidíme, co každé nastavení provádí.  

Pod volbou Edith Methods se skrývají nastavení pro editaci. Nejzajímavější je tu 
možnost Duplicate with object, která určuje, co všechno se má při kopírování objektu 
přenést. Dále bychom měli uvést možnost Undo, kde zadáme určitý počet kroků, které si 
má Blender zapamatovat. Tudíž se jedná o příkaz „zpět“. Neposlední možností je tu Switch 
to Edit Mode, což zajistí, že při přidání nového objektu se automaticky přepneme do 
editačního režimu. 

Třetí volbou je Language & Font. V tomto si můžeme vybrat jazykovou lokalizaci 
prostředí. Na výběr je zde více jak dvě desítky jazyků včetně českého. Po výběru jazyka si 
ještě můžeme vybrat, na jaké prvky se překlad bude vztahovat (Tooltips, Buttons, 
Toolbox). 

Další čtvrtou volbou je Themes, ve které si můžeme nastavit vzhled prostředí. 
Máme zde volbu mezi třemi možnostmi. První je standardní vzhled (Default). Další 
vzhled, který je k dispozici, je Rounded. Poslední třetí možností je vzhled, který si jako 
uživatelé můžeme vytvořit sami (New User Theme). 

Pátou volbou je Auto Save, která jak už název napovídá, umožňuje nastavit 
časovou frekvenci automatického ukládání. 

Šestá volba nebude pro běžného uživatele příliš využitelná. Jedná se o System & 
OpenGL. Tato možnost zajišťuje zpracování a výstup grafických algoritmů programu. 
Mezi nejužitečnější volbu zde patří Emulate Numpad, kdy klávesy 0-9 emulují numerickou 
část klávesnice, což je velmi výhodné, jestliže pracujeme na notebooku.  
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Poslední volbou je File Paths, kde si můžeme nastavit cesty k adresářům, ve 
kterých se mají vytvářet či vyhledávat soubory. Jsou to zejména soubory pro fonty, 
vykreslování, Python skripty, textury atd. 

Nyní si zmíníme důležitou věc, kterou je uložení těchto změn. Kdybychom Blender 
zavřeli a poté znovu spustili, zjistili bychom, že naše provedené změny zmizely. Proto, 
pokud si chceme vytvořit vlastní nastavení, které chceme mít při každém spuštění 
Blenderu, musíme si ho nejprve uložit. Toto provedeme příkazem Save Default Settings, 
který najdeme v okně User Preferences v nabídce File. Při příštím spuštění se nám v 
Blenderu zobrazí nastavení a vzhled prostředí tak, jak jsme si jej změnili včetně toho, co 
jsme v Blenderu vytvořili. 
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4 Způsoby a možnosti ovládání 

V této chvíli máme znalosti k tomu, abychom si nyní ukázali, jaké jsou základní 
možnosti okna 3D View, tudíž jak nastavíme různé pohledy nebo editování pomocné 
mřížky atd. Ukážeme si, kde najdeme vrstvy, a práci s nimi. Poté si projdeme přidávání 
scénových objektů a jejich základní práce s nimi. 

4.1 Okno 3D View a jeho základní ovládání 

Nejzákladnější operací, jež můžeme vidět v okně 3D View, jsou beze sporu změny 
pohledů. Jako i v jiných 3D grafických programech zde máme čtyři základní pohledy. 
Těmi jsou pohled kamerou, nárys, bokorys a půdorys, který bývá standardně nastaveným 
pohledem po spuštění Blenderu. Změnit pohled můžeme přes menu okna 3D View  volbou 
View, kde máme na výběr, dle zvoleného jazyka, možnosti Side, Front, Top, Camera. 
Vedle těchto příkazů můžeme vidět jejich klávesové zkratky. Klávesové zkratky jsou pro 
používání daleko rychlejší. Naučíme-li se s nimi jako uživatelé pracovat, stane se pro nás 
práce v Blenderu pohodlnější. Aby ovšem klávesové zkratky fungovaly, musíme mít nad 
oknem 3D View umístěný kurzor. Jestliže chceme posunout pohled v nějakém určitém 
směru, stačí, když stiskneme klávesu Shift. Potom stisknutým prostředním tlačítkem 
(kolečko) myši se pohybujeme námi zvoleným směrem. Naopak bez stisknuté klávesy 
Shift funguje stisknuté prostřední tlačítko myši a následné posouvání myši jako otáčení 
daného pohledu námi vybraným směrem. V následující tabulce 1 jsou zpřehledněny další 
základní příkazy, které si můžeme odzkoušet. 

Tabulka 1 - Některé klávesové zkratky okna 3D View 

Název Český název Funkce Klávesová 
zkratka 

Alternativa 

Camera Kamera pohled kamerou NumPad 0 View>Camera 
Top Nahoře pohled shora NumPad 7 View>Top 
Front Ze předu čelní pohled NumPad 1 View>Front 
Side Ze strany boční pohled NumPad 3 View>Side 
Zoom In Přiblížit přiblíží pohled NumPad + kolečko myši 
Zoom Out Oddálit oddálí pohled NumPad - kolečko myši 
View All Zobrazit vše zobrazí všechny 

objekty ve scéně 
Home View>View All 

Zoom Within 
Border 

 vytvoří zoom 
pomocí zadaného 
obdelníku 

Shift + B View>Zoom 
Within Border 

Reset Zoom Resetuj zoom vrátí zoom do 
původního 
nastavení 

NumPad Enter View>View 
Navigation>Reset 
Zoom 
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Jestliže budeme chtít změnit nastavení okna 3D View, můžeme to udělat přes 
nabídkové menu View, kde vybereme možnost View Properties. Po stisknutí této možnosti 
se nám zobrazí karta, kde nás bude zajímat textové pole Grid a 3D Display. Textové pole 
Grid slouží k nastavení vlastností mřížky. Spacing zde znamená, jak velkou hustotu bude 
mřížka mít. Lines zde určuje rozsah mřížky. To znamená, na kolik oblastí se mřížka bude 
dělit. V obrázku 7 je uvedeno číslo 60, tudíž bude mít mřížka 60 oblastí na délku i na šířku. 
Tlačítkem Grid Floor můžeme schovat nebo zobrazit mřížku. Tlačítka X Axix, Y Axis a 
Z Axis fungují podobně. Zobrazují nebo schovávají prostorové osy, kde osa x je vykreslena 
červenou barvou, osa y zelenou a osa z modrou. 

Pro úplnost bychom měli poznamenat, že jednotky v Blenderu jsou zcela obecné. 
To znamená, že záleží na uživateli, jestli pro něj vzdálenost 1 bude znamenat délku 
jednoho metru nebo centimetru. Bylo by ale vhodné nechat nastavení mřížky tlačítkem 
Spacing takové, aby například jeden čtverec odpovídal jednomu metru. 

 

Obrázek 7 – Nastavení vlastností okna 3D View 

Dalším způsobem zobrazování je Draw type neboli typ vykreslení. Můžeme ho 
provést pomocí nabídky, kterou vidíme na obrázku 8. Standardně je zvolen typ zobrazení 
Solid, což znamená, že objekt je zobrazen s vyplněnými plochami. Další nejčastěji 
používanou volbou je Wireframe, tzv. drátěný model. To znamená, že plochy se na 
objektech nezobrazují. Další obdobou zobrazení typu Solid jsou Textured a Shaded, které 
navíc berou v potaz nastavení materiálových vlastností a světelných zdrojů. Poslední 
volbou je Bounding Box, který nezobrazuje standardní objekty v jejich skutečném tvaru. 
Namísto nich zobrazuje krychle, kde jejich velikost odpovídá velikosti objektů původních. 
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Obrázek 8 – Způsoby zobrazení 

4.2 Okno Buttons Window 

Tento typ okna si musíme dobře zapamatovat, protože v Blenderu patří mezi 
nejpoužívanější. Nalezneme zde velké množství příkazů pro práci s objekty ve scéně. Tyto 
příkazy jsou zde shrnuty do šesti nabídek, kde každá má svůj specifický význam. Přepínat 
se mezi těmito nabídky můžeme buď přímo přes nabídkové menu Panels nebo kliknutím 
na jednu z šesti ikon, které vidíme na obrázku 9. Další možností jsou klávesové zkratky 
uvedeny v tabulce 2. 

 

Obrázek 9 - Okno Button Window s jeho hlavními nabídkami 

První možností je panel Logic (1), který slouží pro tvorbu tzv. herní logiky. Další 
možností je panel Script (2) sloužící pro Python skripty. Následující panel je Shading (3), 
který v sobě zahrnuje příkazy pro stínování, materiálové nastaveni a textury. Čtvrtý panel 
nese název Object (4). V tomto panelu nalezneme příkazy pro práci s objekty. 
Předposledním panelem je Editing (5), který slouží pro editaci objektů v editačním režimu. 
V posledním panelu s názvem Scene (6) nalezneme příkazy pro nastavení renderu a 
animování. S většinou z těchto nabídek se setkáme v pozdějších kapitolách. 
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Tabulka 2 - Nabídky a klávesvé zkratky okna Buttons Window 

Název Český název Funkce Klávesová 
zkratka 

Alternativa 

Render Renderování vyrenderuje scénu F12 
Render>Render 
Current Frame 

Scene Scéna 
nabídka pro práci 
se scénou F10 Button Window  

Editing Editace 

nabídka pro práci s 
objektem v 
editačním módu F9 Button Window 

Object Objekt 
nabídka pro práci s 
objektem F7 Button Window 

Logic Logika 
nabídka pro tvorbu 
herní logiky F4 Button Window 

Script Skript 
nabídka pro Python 
skripty  Button Window 

Shading Stínování 
nabídka pro 
stínování F5 Button Window 

 

4.3 Manipulátory 

Manipulátory slouží pro zjednodušení operací, které s objektem můžeme provádět. 
Těmito operacemi máme na mysli posun, rotaci a změna měřítka. 

Manipulátory můžeme vidět vždy kolem středového bodu vybraného objektu. 
Jejich výběr nalezneme na spodní části okna 3D View, jak vidíme na obrázku 10 v černém 
polygonu. První ikona s obrázkem ruky má za funkci povolení či zakázání zobrazení 
manipulátorů. Další tři ikony určují, který typ manipulátoru se zobrazí. Máme tu 
manipulátor pro posun (Translate), rotaci (Rotate) a změnu měřítka (Scale). Jestliže 
chceme používat více manipulátorů zároveň, stačí držet klávesu Shift a poté klepat na 
příslušné ikony. Poslední volbou je tu rozbalovací nabídka, ve které si můžeme zvolit 
orientaci manipulátorů. View udává, že manipulátory budou orientovány ve směru pohledu. 
U Normal budou orientovány ve směru normál. Volba Global určuje orientaci globálním 
souřadnicovým systémem a Local pro změnu lokálním souřadnicovým systémem. 

 

Obrázek 10 - Nabídka pro ovládání manipulátorů 
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Obrázek 11 - Typy manipulátorů 

Manipulátory tedy v podstatě fungují tak, že pokud klikneme levým tlačítkem myši 
na kterýkoliv z nich, bude se transformace provádět v určitém směru. Například klikneme-
li na červenou kružnici (obrázek 11), bude objekt rotovat jen podle osy x. 

4.4 Středový bod a zarovnávání 

Středový bod reprezentuje objekt jako takový a dají se k němu provádět 
transformace. Pokud do scény vložíme nový objekt, tento středový bod se objeví na místě 
kurzoru a zároveň je celý objekt umístěn tak, že se tento středový bod nachází v jeho těžišti 
[1]. 

Jestliže chceme středový bod objektu přesunout kamkoliv jinam, existují pro tuto 
operaci v Blenderu tři základní tlačítka, která se nachází v editačním menu okna Buttons 
Window. Těmito tlačítky jsou Centre, Centre New a Centre Cursor. Celý tento panel 
vidíme na obrázku 12. Příkaz Center provede úkon, který přemístí zvolený objekt tak, aby 
se jeho středový bod nacházel v jeho těžišti. Příkaz Centre New naopak přesune středový 
bod do těžiště jeho objektu. A volbou Center Cursor se středový bod zvoleného objektu 
přemístí na pozici kurzoru. 

 

Obrázek 12 - Panel editačního menu s příkazy pro práci se středovým bodem 

Další využití středového bodu využíváme u přesného zarovnání objektů. 
Zarovnávání je v Blenderu řešeno přes nabídku Object>Snap. Tuto nabídku můžeme vidět 
na obrázku 13. Pojďme si popsat, jakou funkci mají jednotlivé příkazy. Příkaz Selection -> 
Grid zarovná vybraný objekt tím způsobem, že jeho středový bod umístí na nejbližší bod 
pomocné mřížky. Jestliže chceme přemístit vybraný objekt tak, aby jeho středový bod byl 
na místě kurzoru, zvolíme volbu Selection -> Cursor. Volbou Selection -> Center   
přesuneme všechny vybrané objekty do středu těchto objektů. Tudíž tyto objekty mají 
stejnou polohu. Čtvrtým příkazem je Cursor -> Selection, který přemístí kurzor do 
středového bodu vybraného objektu.  Volba Cursor -> Grid přesune kurzor na nejbližší bod 
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pomocné mřížky. Poslední příkaz Cursor -> Active posune kurzor do středového bodu 
objektu, který je nebo byl poslední vybrán. 

 

Obrázek 13 - Nabídka pro zarovnávání 

4.5 Skupiny 

Jestliže chceme, aby se stejná operace prováděla pro více objektů, je vhodné si 
vytvořit tzv. skupinu objektů. 

Pokud chceme nějaký objekt vložit do skupiny, provedeme to následovně. V menu 
pro práci s objekty v okně Buttons Window nalezneme panel Object and Links. Tento panel 
vidíme na obrázku 14. Nyní již stačí kliknout na tlačítko Add to Group a námi vybraný 
objekt se nám přiřadí do skupiny. Tuto skupinu si můžeme podle svého přání přejmenovat. 
Nyní vidíme, že objekt má místo růžových obrysů zelené. To znamená, že byl přiřazen do 
skupiny. Přidáním nových objektů a jejich přiřazením do stejné skupiny provedeme 
podobně, jen s rozdílem, že vybereme již naši vytvořenou skupinu. Jestliže bychom chtěli 
objekt ze skupiny odebrat, stačí mít objekt vybraný a na panelu Object and Links kliknout 
na ikonu kříže. Po přidání několika objektů do stejné skupiny můžeme klávesovou 
zkratkou Alt  + Shift a zároveň pravým tlačítkem myši vybrat objekt. Uvidíme, že se nám 
vybraly všechny objekty, které patří stejné do skupiny (obrázek 14). Poté už lze na všechny 
objekty ve skupině aplikovat například transformace, které jsou popsány v kapitole 4.10. 

 

Obrázek 14 - Panel Object and Links a objekty ve skupině 
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4.6 Vrstvy 

S vrstvami se v dnešní době můžeme setkat u všech lepších 2D i 3D grafických 
programů. Vrstvy umožňují nezávislou a přehlednější práci ve scéně. Při velkém množství 
objektů by byla práce velmi chaotická. Význam vrstev je ale v Blenderu daleko větší. 
Například zde můžeme určit, co se má vykreslit nebo určit, jaké světelné zdroje mají 
ovlivňovat jaké objekty. V Blenderu můžeme maximálně využít 20 vrstev a můžeme je 
vidět zobrazeny v panelu okna 3D View v podobě malých čtverců. Na obrázku 15 jsou 
zvýrazněny černým obdélníkem. 

Pro zobrazení toho, co se nachází v dané vrstvě, klikneme na vrstvu, kterou 
požadujeme. Pokud bychom podrželi stisknutou klávesu Shift a stisknuli jednotlivá 
tlačítka vrstev, můžeme si tímto způsobem zobrazit obsahy více hladin najednou. 

Jestliže do scény vložíme nějaký objekt, pak se tento objekt vloží vždy do vrstvy, 
která je momentálně aktivní. Pokud bychom však chtěli vrstvu u vybraného objektu 
změnit, musíme mít kurzor myši umístěn nad oknem 3D View, a pak už stačí stisknout 
klávesu M . Poté si jen z nabídky vybereme vrstvu, kam chceme objekt přesunout. 

Zámek, který můžeme na obrázku 15 vidět, značí, zda se změny vrstev v jednom 
okně projeví i v ostatních oknech 3D View. Tudíž je-li zámek zamčený, změny se 
v ostatních oknech projeví. Je-li tomu naopak, změny se neprojeví. 

 

Obrázek 15 – Vrstvy 

4.7 Scénové objekty 

Jestliže chceme do scény přidat nějaký objekt, můžeme to udělat přes okno User 
Preferences prostřednictví rozbalovací nabídky Add. Tentýž účinek má klávesa Space, 
navíc se nám zde zobrazí příkazy pro editaci, rendering, transformaci atd. To už ale 
odbíháme. Pojďme si probrat, co nám naskýtá ona nabídka Add, kterou vidíme na obrázku 
16. 

 

Obrázek 16 - Rozbalovací nabídka pro přidání nových objektů 
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• První možností je nabídka Mesh. Tato nabídka je v Blenderu nejpoužívanější, 
protože skrývá objekty, které se skládají z vertexů, hran a ploch. Většinu ostatních 
typů objektů převádíme v konečné fázi na mesh objekty. 

• Nabídka typu Curve slouží pro vkládání křivek, kterými vytváříme objekty 
s oblými tvary. V Blenderu existují dva typy křivek. První z nich jsou křivky 
Bezierovy, které jsou dány svými koncovými řídícími body. Druhým typem křivek 
jsou tzv. NURBS křivky, pro které se v Blenderu používá množství parametrů. 
Obecně jsou to křivky, které jsou definovány svým pořadím, skupinou kontrolních 
bodů s různou váhou a uzlovými vektory.  

• Třetí nabídkou je Surface neboli plochy. Jsou to vlastně křivky, které byly 
rozšířeny o jednu dimenzi. 

• Meta objekty, které se hodí pro tvorbu organických modelů a jsou popsány 
matematickými vzorci. Tyto objekty mohou vykonávat logické operace s jinými 
objekty. Takto popisujeme tzv. CSG objekty (Constructive Solid Geometry), pro 
které je charakteristické, že mají malou spotřebu paměti. 

• Nabídkou Text vkládáme do 3D prostředí text. 

• Objekt Empty znamená, že ve scéně vytvoříme „prázdný“ objekt. Tento objekt není 
ve scéně vidět, přesto má své využití. Například v částicovém systému. 

• Group neboli skupina. Tato volba seskupuje objekty do námi vytvořené skupiny. 

• Volba Camera vkládá do scény novou kameru. Jelikož se rendering provádí 
z pohledu jen jedné kamery, musíme si novou kameru nastavit jako aktivní. Práci 
s kamerou si popíšeme v pozdější kapitole. 

• Volbou Lamp vkládáme do scény nový zdroj světla. I zdroje světla si popíšeme 
v pozdější kapitole. 

• Předposlední volba jsou tzv. armatury. Jsou to objekty, které se používají ve 
specifických animacích, jako je například lidská chůze. 

• Poslední volbou je objekt Lattice, který představuje trojrozměrnou mřížku vertexů, 
sloužící například pro deformaci objektů. 

4.8 Objektový a edita ční režim 

Abychom mohli pracovat s objekty, musíme si vysvětlit pojem objektový a editační 
režim. Hlavní rozdíl mezi těmito režimy je, že objektový režim pracuje s objektem jako 
celkem. Editační režim oproti tomu pracuje s částmi objektu. To znamená, že může 
pracovat s vertexy, hranami a plochami zvlášť. Jestliže do Blenderu vložíme nějaký nový 
typ objektu, vždy je tento objekt v režimu objektovém. Jedinou výjimkou jsou objekty typu 
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Empty, Group, Camera a Lamp, které editační režim nemají, proto pracují jen 
v objektovém režimu. 

Jestliže se chceme dostat do editačního režimu, provedeme to následovně. Po 
spuštění Blenderu máme ve scéně standardně krychli, která je již označená. To je důležité, 
protože jestliže chceme přejít do editačního režimu objektu, musíme mít tento objekt 
označený, což provedeme klepnutím pravým tlačítkem myši na námi požadovaný objekt. 
Dále již stačí v okně 3D View vybrat editační režim dle obrázku 17. Všimněme si, jak se 
nám změnila krychle po přechodu do editačního režimu. Dále si můžeme povšimnout, že 
nabídka textového menu Object se změní na Mesh, pokud se přepneme do editačního 
režimu. Tato nabídka se mění dle typu objektu. Kdyby byl například objekt typu Meta, 
textové menu by se změnilo na Metaball. 

 

Obrázek 17 - Objektový a editační režim 

4.9 Příkazy pro výb ěr objekt ů 

Program Blender disponuje mnoha příkazy pro vybírání objektů, které vidíme na 
obrázku 18. My si nyní stručně popíšeme jejich funkce. 

 

Obrázek 18 - Možnosti výběru objektů 

• První možností je Grouped. Díky této nabídce můžeme objekty vybírat podle toho, 
do jaké skupiny patří. Například dle barvy, skupiny, nebo můžeme vybrat objekty, 
které patří do stejné vrstvy. 
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• Další volbou je Select All by Type. Jak už z názvu vyplývá, tímto příkazem 
vybereme všechny objekty dle určitého typu. Například všechny objekty typu mesh. 

• Podobná volba Select All by Layer vybírá všechny objekty, které patří do určité 
vrstvy. 

• Možnost Random vybírá objekty ze scény podle náhodného kritéria. Po výběru 
příkazu se nám zobrazí okno s nastavitelnými procenty, které udávají míru 
vybraných objektů. 

• Volba Inverse vybírá objekty inversně. Tudíž co bylo vybráno, se odznačí, a 
naopak. 

• Select/Deselect All vybírá nebo odznačí všechny objekty ve scéně. 

• Volba Border Select, tzv. obdélníkový výběr, vybírá objekty pomocí tažení myši. 
Vyberou se všechny objekty, které alespoň zčásti spadají do tohoto výběru. 

Následující tabulka (Tabulka 3) zobrazuje přehled příkazů pro výběr objektů. 

Tabulka 3 - Příkazy pro výběr objektů 

Název Český název Funkce Klávesová 
zkratka 

Alternativa 

Select/Deselect 
All 

Vybrat/Odebrat 
vše 

přepínáč pro 
výběr či 
odznačení všeho A 

Select>Select/Deselect 
All 

Border Select 
Obdelníkový 
výběr 

obdélníkový 
výběr B Select>Border Select 

Inverse Inversní výběr obrácený výběr Ctrl + I Select>Inverse 

Random Náhodný výběr 

označí objekty dle 
procentuálního 
počtu  Select>Random 

4.10 Příkazy pro transformace 

Transformace patří mezi nejzákladnější operace mezi všemi grafickými programy, 
nechybějí ani v Blenderu. Mezi tyto příkazy patří posun, rotace, změna měřítka a zrcadlení. 
Příkazy najdeme v nabídkách Object>Transform a Object>Mirror (viz. Obrázek 19, 21). 
Pojďme si probrat, jaké možnosti tyto transformace poskytují. 

Příkaz Grab/Move provádí změnu polohy objektu. Jestliže vybereme objekt a 
provedeme na něj tento příkaz, můžeme s objektem pohybovat dle svého uvážení. Až 
budeme s novou polohou spokojeni, stačí potvrdit klepnutím levého tlačítka myši. 
Podobným způsobem provádíme příkaz Rotate, který funguje pro otáčení objektů. Změnu 
měřítka provádíme příkazem Scale. 
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Obrázek 19 - Rozbalená nabídka s příkazem pro posun 

Jak vidíme na obrázku 19, mohou transformace využívat globálního nebo lokálního 
souřadnicového systému. Rozdíl mezi globálním a lokálním souřadnicovým systémem 
spočívá v tom, že globální je využíván celou scénou. Toto jednoznačné určení je pro 
všechny objekty stejné. Oproti tomu lokální souřadnicový systém je určen ku poloze 
středového bodu objektu. V Blenderu je každý objekt reprezentován svou polohou, 
orientací a měřítkem, což si můžeme zobrazit pomocí příkazu Transform Properties. Po 
zadání tohoto příkazu se nám otevře nové okno obsahující numerické informace o objektu, 
které můžeme i editovat. Zmíněné okno můžeme vidět na obrázku 20. 

 

Obrázek 20 - Krychle a její transformační vlastnosti 

Všimněme si na obrázku 19, že máme k dispozici ještě další možnosti pro posun, 
rotaci, měřítko, a to jsou Grab/Move on Axis, Rotate on Axis a Scale on Axis. Tyto příkazy 
znamenají, že zmíněné transformace se budou provádět na námi zvolené ose, tudíž buď na 
ose x, y nebo z. 

Transformace zrcadlení provedeme přes nabídku Object>Mirror. Po vyvolání této 
nabídky se nám objeví čtyři příkazy, které můžeme vidět na obrázku 21. První volbou je 
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Interactive mirror neboli tzv. interaktivní zrcadlení. Tímto příkazem určujeme osu 
zrcadlení až přímo ve scéně. Další příkazy, kterými jsou X Local, Y Local a Z Local. Jsou 
to typy zrcadlení, které zrcadlí objekt v příslušné ose.  

 

Obrázek 21 - Rozbalovací nabídka zrcadlení 

V následující tabulce je zobrazen přehled nejdůležitějších příkazů pro transformace. 

Tabulka 4 - Příkazy prot transformace objektů 

Název Český název Funkce Klávesová 
zkratka 

Alternativa 

Grab/Move Posun posune objekt G Object>Transform>Grab/Move 
Rotate Rotace rotace s 

vybraným 
objektem 

R Object>Transform>Rotate 

Scale Změna velikosti změna velikosti 
objektu 

S Object>Transform>Scale 

Mirror Zrcadlení zrcadlí objekt, 
ve směru osy 

Ctrl + M Object>Mirror>Interactive 
mirror 

4.11 Další důležité p říkazy programu Blender 

V této části kapitoly si shrneme další nejdůležitější příkazy programu Blender. 
Nebudeme si je tu zmiňovat všechny, ale vytyčíme ty nejpoužívanější. Vzhledem 
k rozsáhlosti příkazů a klávesových zkratek, budou ostatní příkazy publikovány v praktické 
části mé bakalářské práce. 



31 
 

 

Tabulka 5 - Přehled důležitých příkazů programu Blender 

Název Český název Funkce Klávesová 
zkratka 

Alternativa 

Add Vložit vkládání 
objektů do 
scény 

Mezerník User Preferences>Add 

Delete Smazání 
objektu 

smaže vybrané 
objekty 

Delete, X Object>Delete 

Duplicate  Kopírovat nová nezávislá 
kopie 

Shift + D Object>Duplicate 

Group Skupina přiřadí objekt ke 
skupině 

Ctrl + G Object>Group 

Bool Tools Boolean 
nástroje 

operace typu 
rozdíl, průnik a 
rozdíl 

W Object>Boolean Operation 

Set layer Nastavení 
hladiny 

vybrané objekty 
nastaví do námi 
vybrané hladiny 

M Set layer 

Open Otevřít otevře soubor F1 File>Open 
New Nový začneme od 

začátku, ztráta 
všech objektů 
ve scéně 

Ctrl + X File>New 

Save Default 
Settings 

Uložit defaultní 
nastavení 

uloží 
uživatelské 
nastavení ja 
defaultní 

Ctrl + U File>Save Default Settings 

Save Uložit uloží soubor a 
přepíše původní 

Ctrl + W File>Save 

Save as Uložit jako uložení do 
nového souboru 

F2 File>Save as 
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5 Modelování a modifikace scénových objekt ů 

V kapitole si popíšeme, s jakými modelovacími technikami můžeme v programu 
Blender pracovat. Dále si ukážeme způsoby jak objekty modifikovat. Modelování se 
nejčastěji provádí na objekty typu mesh. Proto si tu také ukážeme, jaké základní mesh 
objekty Blender obsahuje. 

5.1 Mesh objekty 

Mesh objekty, neboli základní tvary v programu, Blender jsou objekty, které se 
skládají z vertexů, hran a ploch. Tyto základní tvary lze vymodelovat dle specifických 
modelovacích metod. Na obrázku 22 vidíme tyto základní tvary. Pojďme si je stručně 
představit. 

 

Obrázek 22 - Přehled základních objektů typu mesh 

• Plane je čtverec, který je tvořen čtyřmi vertexy, jednou plochou a čtyřmi 
hranami. Ze čtverce můžeme například vytvářet stěny a další objekty, které 
nevyžadují tloušťku. 

• Objekt Cube (krychle), který se vkládá standardně do scény jako první. 
Objekt se skládá z 8 vertexů, 12 hran a z 6 ploch. Z krychle můžeme tvořit 
objekty typu kostka nebo kvádr.  

• Circle je 2D kružnice, což znamená, že nemá žádnou plochu. Objekty, které 
tvoříme z kružnice, jsou například různá DVD media, pro která je kružnice 
základem. 
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• UVsphere je koule, která je složena ze segmentů, které bychom přirovnali 
k zemským poledníkům, a prstenců, které se dají přirovnat k zemským 
rovnoběžkám. Tyto parametry zadáváme při vložení objektu do scény. 
Příklad objektu UVsphere je například míč nebo planeta. 

• Icosphere je koule složená z trojúhelníkových segmentů. Při vložení objektu 
do scény zadáváme tzv. Subdivision, který udává počet rozdělení 
trojúhelníků. Čím vyšší je hodnota Subdivision, tím více bude koule 
vyhlazená. 

• Objekt Cylinder je obyčejný válec, který najde využití při modelování všech 
válcových objektů, jako jsou například trubky atd. 

• Cone (kužel) je objekt, který se používá pro modelování nejrůznějších 
zašpičatělých objektů. 

• Grid je objekt, u kterého při vložení do scény zadáváme počet vertexů na 
výšku a na šířku. Můžeme si povšimnout jeho podobnosti s objektem Plane, 
ale jeho výhodou je, že může mít daleko více vertexů, což je například 
vhodné při modelování různých ploch jako jsou krajiny. 

• Monkey je hlava opice. Vývojáři Blenderu ještě za působení firmy Not a 
Number tuto hlavu vymodelovali jako základní tvar. Jmenuje se Suzanne a 
slouží Blenderu jako maskot. 

• Empty mesh funguje podobně jako objekt Empty, který nemá ve scéně 
žádný význam. I tak se může využít pro nějaké speciální grafické operace. 

• Torus neboli anuloid je určen hlavním poloměrem a poloměrem opisované 
kružnice. Dále se zde zadává počet segmentů, ze kterých se anuloid skládá, 
a počet vertexů v jednom kruhovém segmentu. Anuloid můžeme použít pro 
různé kroužkové objekty. 

5.2 NURBS objekty ( Surfaces) 

NURBS (non uniform rational B-spline) plochy jsou velice variabilní a nabízejí 
velikou flexibilitu a přesnost při manipulaci. Tyto plochy používají dvourozměrnou 
interpolaci. To znamená, že dvourozměrná mřížka řídících bodů určuje tvar plochy. Rozdíl 
mezi objekty mesh a objekty surface spočívá v tom, že objekty mesh modifikujeme dle 
jejich vertexů, hran nebo ploch. Objekty surface modifikujeme dle jejich mřížky. Na 
obrázku 23 můžeme vidět NURBS Curve (NURBS křivka), NURBS Circle (NURBS kruh), 
NURBS Surface (NURBS povrch), NURBS Tube (NURBS trubka), NURBS Sphere 
(NURBS koule) a NURBS Donut (NURBS prstenec). 
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Obrázek 23 - Přehled Surface objektů 

5.3 Modifikace scénových objekt ů 

Modifikace scénových objektů se v Blenderu provádí velmi často, proto existuje 
celá řada modifikačních nástrojů a příkazů. V této kapitole si probereme jen některé z nich. 

5.3.1 Modifikátory 
Modifiers neboli modifikátory jsou nástroje, které se specializují na editaci objektů. 

Tyto nástroje pracují s různými typy objektů, proto jeden modifikátor nemusí fungovat na 
každý objekt stejně. Mnoho editačních funkcí v Blenderu má svůj ekvivalentní protějšek 
v podobě modifikátoru. Například příkaz Bevel, který zaobluje nebo zakřivuje hrany, 
funguje stejným způsobem jako modifikátor Bevel. 

Pojďme si ukázat, kde modifikátory najdeme, a demonstrovat si jeden modifikátor 
prakticky. Modifikátory nalezneme v menu pro editaci v okně Buttons Window, tedy v tom 
nejspodnějším okně po spuštění Blenderu. Dostaneme se tam i klávesou F9. Zprvu vidíme, 
že panel neobsahuje žádný modifikátor. Proto ho tlačítkem Add Modifier přidáme a 
z nabídky vybere Subsurf na námi vybranou krychli. Funkce modifikátoru Subsurf spočívá 
v tom, že vyhlazuje objekt do více propracovanější sítě. Na jeden objekt se dá použít i více 
modifikátorů. Zkusme ještě přidat k vybrané krychli modifikátor Bevel, který zaobluje 
ostré hrany. Další důležitou připomínkou je, že u modifikátorů záleží na pořadí, ve kterém 
jsou seřazeny. Jestliže bude modifikátor Bevel na prvním místě před Subsurf, bude vždy 
výsledek jiný než v opačném pořadí. Zkusme tedy experimentovat, měnit nastavení 
v modifikátorech a pozorovat, jak se krychle mění. Až budeme s výsledkem spokojeni, 
stačí tlačítkem Apply změnu potvrdit. Změny se stanou trvalými. Aplikovat modifikátory 
lze jen v objektovém režimu, ne v editačním. Na obrázku 24 můžeme vidět krychli, na 
kterou byl aplikován modifikátor Subsurf na druhé úrovni. 
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Obrázek 24 - Modifikátor Subsurf 

5.3.2 Nástroj Subdivide 
Obyčejný příkaz Subdivide pracuje tak, že každou vybranou hranu rozdělí na dvě 

části. To znamená, že do každé vybrané hrany přidá jeden vetex. V Blenderu ale máme 
více typů příkazu Subdivide. Pojďme se seznámit i s ostatními. 

• Subdivide Multi neboli násobné rozdělení. Po zadání toho příkazu uživatel 
zadá počet vertexů (Number of Cuts), které se mají do hrany přidat. Tyto 
vertexy se na hraně rozmístí rovnoměrně. 

• Subdivide Multi Fractal je podobný příkaz jako předchozí, ale rozdíl je 
v tom, že nové vertexy jsou rozmístěny nerovnoměrně. Dále se tu zadává 
ještě jedna hodnota (Rand Fac), která určuje odchylku polohy vertexu, 
kdyby byl vertex umístěn rovnoměrně. 

V následujícím obrázku 25 je znázorněna plocha krychle, na kterou byl čtyřikrát 
aplikován příkaz Subdivide. Ještě si můžeme povšimnout, že nám vznikají nové hrany a 
plochy i na plochách, které jsme nerozdělovali. 

 

Obrázek 25 - Rozdělená plocha krychle 
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5.3.3 Nástroj Extrude 
Podobný nástroj pro modelování objektů, jenž objekty vytahuje, se nazývá Extrude 

(vytažení). Nachází se v Mesh>Extrude. Po stisknutí příkazu se nám zobrazí nabídka se 
čtyřmi příkazy, které můžeme vidět na obrázku 26. 

 

Obrázek 26 - Rozbalovací nabídka Extrude 

Prvním příkazem je Region, který vytáhne všechny zvolené části ve směru pohybu 
myši. Individual Faces reprezentuje tažení ve směru normál námi zvolených ploch. Na 
obrázku 27 můžeme vidět, co nám příkaz Individual Faces provede s krychlí, která má 
označené všechny plochy. Příkaz Only Edges vytahuje pouze vybrané hrany objektu a 
příkaz Only Vertices naopak jen označené vertexy ve směru pohybu myši. 

 

Obrázek 27 - Krychle po aplikace příkazu Extrude>Individual Faces 

5.4 Modelování scénových objekt ů 

5.4.1 Modelování objekt ů pomocí transforma čních p říkazů  
Jestliže bychom chtěli modelovat nějaký scénový objekt, v našem případě objekt 

typu mesh, provádíme to tak, že se nejprve přepneme do editačního režimu. Objekty 
modelujeme tím, že měníme polohu, orientaci a velikost jeho vertexů, hran či ploch. 
Pojďme si ukázat na jednoduchém příkladu, jak vymodelovat krychli tak, aby se z ní stal 
kvádr. 

První krokem je, že se přepneme do editačního režimu. Z předchozích kapitol už 
víme jak. Jak vidíme na obrázku 28, krychle se nám změnila do světle fialového nádechu. 
Můžeme si všimnout, že se nám změnilo více věcí než ona zmíněná krychle. Příkazy a 
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tlačítka, které se používají v editačním režimu, nenajdeme v objektovém režimu. Tudíž 
vidíme, že i panel pro vrstvy zhruba nahradil jiný, který můžeme vidět na obrázku 28 
v červeném rámečku. Tento panel se nazývá mód výběru. V něm se nacházejí čtyři 
tlačítka. Prvním z nich je tlačítko se čtyřmi tečkami. Když je tlačítko aktivní, budou se nám 
vybírat jen vertexy objektu. S druhým tlačítkem s podobou lomítka se nám budou vybírat 
jen hrany a na třetím, na kterém je vyobrazen trojúhelník, se budou logicky vybírat jen 
hrany objektu. Poslední tlačítko s vyobrazenou krychlí funguje tak, že povolí nebo zakáže 
vykreslení odvrácených vertexů, hran a ploch. V Blenderu se dají tato tlačítka i 
kombinovat, a to podržením klávesy Shift. Například může být najednou povolen výběr 
hran i ploch. 

  

Obrázek 28 - Krychle v editačním režimu s možnostmi výběru 

Klikněme si na tlačítko pro výběr ploch a vyberme např. boční plochu. V tomto 
případě pracujeme s pohledem kamery. Po výběru plochy provedeme transformaci posunu 
klávesou G a následně stiskneme klávesu X, aby byl posun proveden v ose x. Výsledek 
můžeme vidět na obrázku 29. 

 

Obrázek 29 - Krychle změněná na kvádr 
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5.4.2 Modelovaní dle nástroje sculpt 
Dalším nástrojem pro modelování je sculpt, což v překladu znamená modelovat 

sochařskými technikami. Je to tedy modelovací nástroj, který modeluje objekty pomocí 
štětce. Tento štětec však nijak nepřidává ani neodebírá vertexy, pouze mění polohu vertexů 
v závislosti na vybraném štětci a jeho vlastnostech. Tento nástroj je tedy vhodný pro 
modelování krajin nebo organických objektů. 

Nástroje Sculpt spadá do režimů, tudíž jestliže s ním chceme pracovat, musíme se 
do něj přepnout, podobně jako do režimu editačního. Jediný rozdíl je, že vybereme Sculpt 
mode, jak můžeme vidět na obrázku 30 (vlevo). Po přepnutí do tohoto režimu uvidíme, že 
nám kurzor myši nahradila kružnice, která udává velikost štětce. Dále si můžeme 
všimnout, že nám v okně Buttons Windows v menu pro editaci přibyly tři panely pro 
správu tvaru a velikost deformace štětce. Jsou to panely Sculpt, Brush a Texture (obrázek 
30 vpravo).  

 

Obrázek 30 - Režim Sculpt (vlevo) a panel Sculpt (vpravo) 

Na panelu Sculpt se nachází hlavní nastavení. Vidíme zde sedm typů štětců. Štětec 
Draw, který tvaruje vyvýšeniny nebo prohlubeniny. Smooth je typ štětce, který vyhlazuje 
plochy. Štětec Pinch přibližuje vertexy ke středu nebo od středu štětce. Inflate provádí 
posun vertexů dle příslušných normál. Štětec Grab modeluje skupinu vertexů pomocí 
pohybu myši. Typ Layer je podobný jako Draw s tím rozdílem, že se přidává vrstva, která 
určuje maximální velikost pro vyvýšení nebo prohloubení. Poslední typ štětce je Flatten, 
který způsobuje zplošťování. 

U štětců typu Draw, Pinch Inflace a Layer jsou zpřístupněna tlačítka Add a Sub, 
která přidávají nebo odebírají. Například jestliže u štětce typu Draw bude aktivované 
tlačítko Add, budeme vytvářet vyvýšeninu. Naopak u tlačítka Sub se bude vytvářet 
prohlubenina Aktivované tlačítko Airbrush znamená, že deformace bude probíhat bez 
pohybu myši. Posuvné tlačítko Size určuje velikost štětce a posuvným tlačítkem Strength 
zadáváme sílu deformace. Nabídka Symmetry udává směr deformace, takže pokud bychom 
chtěli deformovat například podle osy x, stačí zaškrtnout tlačítko X. Naopak omezení 
deformace v jednotlivých osách docílíme tlačítky pod nápisem LockAxis. 

5.4.3 Modelování dle m řížky 
Mříž neboli Lattice patří k hlavním objektům Blenderu. Tato mřížka se 

nerenderuje, ale dají se podle ní modelovat jiné objekty. Jestliže chceme modelovat přes 
Lattice, musíme si nejdříve povědět o tzv. rodičovské vazbě. 
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Rodičovská vazba v Blenderu představuje pojem, že jeden objekt (rodič) má nějaký 
vztah k jiným objektům (potomkům). Tento vztah bychom mohli definovat tak, že pokud 
například provedeme nějakou transformační operaci s rodičem, tato změna se projeví i na 
potomcích. Uveďme si příklad. Do scény si vložíme kouli a krychli a budeme chtít, aby 
krychle byla rodičem koule. Pokud chceme, aby nějaký objekt byl rodičem, musí být 
vybrán jako poslední. Vybereme tedy nejdříve kouli a za stisknuté klávesy Shift pak i 
krychli. Poté provedeme příkaz Make Parent, který se nachází v Object>Parent>Make 
Parent. Nyní se mezi krychlí a koulí objeví čárkovaná spojnice, která udává, že mezi 
objekty vznikla rodičovská vazba (obrázek 31). Když zkusíme krychli například změnit 
měřítko, uvidíme, že se měřítko mění i u koule. Jestliže to zkusíme obráceně, uvidíme, že 
měřítko se mění jen u koule. To znamená, že potomek nemůže ovlivňovat rodiče. 

 

Obrázek 31 - Rodičovská vazba 

Teď už máme představu o tom, co je rodičovská vazba. Vraťme se tedy k hlavnímu 
tématu. Mřížka zde funguje jako rodič, který modeluje jiný objekt (potomka). Lattice 
vkládáme do scény přes nabídku Add>Lattice v okně User Preferences. Po vložení si 
můžeme všimnout, že se nám v editačním menu v okně Buttons Window objevil nový 
panel s názvem Lattice. Číselná tlačítka U, V a W udávají, kolik bude mít mřížka vertexů 
v jednotlivých osách. Přepínací tlačítka, která se nacházejí vedle každého číselného 
tlačítka, udávají způsob interpolace, jakým se objekt bude deformovat. Tlačítko Make 
Regular zajistí, že mřížka bude pravidelného tvaru. Vše můžeme vidět na obrázku 32. 

 

Obrázek 32 - Panel pro práci s mřížkou 
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6 Textury a mapování 

Texturace je technika, při které přiřazujeme povrchům reálných objektů, jenž mají 
různé nerovnosti, realistický vzhled. V první fázi se textura vytváří a nastavují se jí 
parametry. V druhé fázi pak určujeme, jaký bude mít účinek na materiál. V konečné fázi se 
materiálové vlastnosti mapují na objekt. 

6.1 Postup nanesení textury v Blenderu 

Pojďme si nyní ukázat jednoduchý příklad, jak na krychli nanést texturu. Prvním 
krokem je, že se u označené krychle přepneme do nabídky Shading v okně Buttons 
Window. Zde se nám zobrazí dvě okna, z nichž první Preview je prázdné a druhé Links and 
Pipeline obsahuje tlačítko Add. Stiskněme tedy zmíněné tlačítko Add. Tímto jsme krychli 
přiřadili materiál a vidíme, že nám přibyly nové možnosti a nabídky. Nás ale bude zajímat 
poslední nabídka Texture. Intuitivně tedy klepněme na tlačítko Add New, čímž přidáme 
novou texturu. Povšimněme si, že nám přibyly dva nové panely. První z nich je Map Input 
a druhý Map To. Všechny tři záložky můžeme vidět na obrázku 33. 

 

Obrázek 33 – Panely Texture (vlevo), Map Input (uprostřed), Map To (vpravo) 

 Máme přiřazenou texturu, nyní si pojďme jednu vybrat. Jistě jsme si všimli, že po 
přepnutí do nabídky Shading, přibylo vedle šesti hlavních tlačítek dalších pět nových, kde 
druhé tlačítko je aktivní. Toto tlačítko s názvem Material Buttons právě používáme a 
přiřazuje se v něm materiál. Přepněme se ale do třetího tlačítka s názvem Texture Buttons, 
kde si nastavíme texturu podle. Na panelu Texture jsme vybrali typ textury Image, což 
znamená, že si texturu vezmeme z externího souboru jako nějaký obrázek. Po výběru typu 
textury se nám zpřístupnil panel Image, kde obrázek nahrajeme. Výsledek můžeme vidět 
na obrázku 34. 

 

Obrázek 34 - Nastevení textury způsobem obrázku 
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6.2 Mapování textury ( Panel Map Input) 

V této chvíli máme na krychli nanesenou texturu, ale všimněme si, že textura není 
nanesena správně. Pro tento případ v Blenderu existuje panel Map Input (obrázek 27 
uprostřed), kde se zadává způsob nanesení textury. Pojďme si ho popsat. Deset tlačítek 
v horním panelu udává, jaké souřadnice se do výpočtu souřadnic textur použijí. Mezi 
nejpoužívanější patří Orco, kde se k výpočtu používají lokální souřadnice objektu. A volba 
Glob, kde se používají globální souřadnice. Ostatní volby si představíme v praktické části 
bakalářské práce. 

Další velmi důležitou vlastností, která udává způsob, jakým tvarem se bude textura 
mapovat, jsou čtyři tlačítka s nápisem  Flat ( rovná plocha), Cube (krychle), Tube (válec) a 
Sphere (koule). Vždy zvolme volbu, která se nejblíže podobá našemu objektu. V našem 
případě zvolme Cube. 

Dvanáct tlačítek, které se nacházejí ve spodní části panelu s nápisy X, Y, Z a tři 
z nich jsou bez popisů, představují nastavení souřadnic textury. Jejich úkol spočívá v tom, 
že pomocí jejich přepínání můžeme souřadnice přepínat a tím měnit jejich směr. Prázdná 
tlačítka vypínají souřadnice. 

Posledními numerickými tlačítky ofsX, ofsY a ofsZ udáváme posun textur ve směru 
všech tří os. Tlačítka sizeX,  sizeY a sizeZ můžeme namapované textuře změnit měřítko. 

Na obrázku 35 vidíme způsob namapování textury na krychli a kouli, kde byl vždy 
změněn způsob mapování 

 

Obrázek 35 - Způsoby nanesení textury 

Posledním panelem je Map To (obrázek 33 vpravo), který určuje, jak bude textura 
ovlivňovat materiál. O tomto panelu a taky o materiálech si povíme něco více v praktické 
části bakalářské práce. 
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7 Práce s osv ětlením a kamerou 

7.1 Zdroje sv ětel 

Světla v Blenderu představují velice důležité objekty, protože i když bude objekt 
vymodelován a otexturován výborně, nemůže nikdy působit dobrým dojmem bez řádného 
osvětlení. V Blenderu  existuje celkem pět světelných zdrojů. Všechny tyto světla i 
s nabídkou pro přidání světel jsou zobrazeny na obrázku 36. Pojďme si je tedy představit. 

• Lamp představuje bodové všesměrové světlo, to znamená, že jeho paprsky 
se rovnoměrně šíří do všech směrů. Pro tento typ světla je charakteristické, 
že se jeho intenzita snižuje podle vzdálenosti od tohoto zdroje [1]. 
V Blenderu toto světlo vypadá jako bod, kolem kterého je kruh (1).  

• Světelný zdroj Sun vrhá rovnoběžné paprsky světla, které mají v zadaném 
směru stále stejnou intenzitu. To znamená, že nezáleží na jeho přesné 
poloze [1]. Blender reprezentuje Sun jako bod s kruhem, ze kterého vychází 
8 čar v podobě paprsků (2). 

• Spot je bodový směrový zdroj světla (reflektor). Tento světelný zdroj je 
hodně používaný. Důvodem je skutečnost, že jako jediný dokáže vrhat stíny 
i bez podpory ray tracingu (globální zobrazovací metoda, která vychází ze 
zpětného sledování paprsku) [1]. Ve scéně je tento zdroj světla 
reprezentován jako bod, kolem kterého je kruh. Tento bod vytváří vrchol 
světelného kužele, kterému můžeme za pomoci rotace měnit směr (3). 

• Hemi je zdroj světla podobný Sun navržený pro případy jako je simulace 
světla přicházejícího z hodně zamračené oblohy. Jde tedy o světelný zdroj 
s rovnoběžnými paprsky o stálé intenzitě [1]. Ve scéně je reprezentován 
jako bod s kruhem, ze kterého vycházejí čtyři čerchované čáry.  

•  Světelný zdroj s názvem Area slouží pro simulaci plošných směrových 
světelných zdrojů (televizní obrazovka, neonová reklama) [1]. Vzhled 
tohoto typu světla je reprezentováno bodem, kolem kterého je kruh a vně 
ještě čárkovaný čtverec (5). 

Práce se světly a jejich umisťování do scény bude řešeno jako jedna z lekcí 
praktické části mé bakalářské práce.  



43 
 

 

Obrázek 36 – Přehled typů světel v programu Blender 

7.2 Kamera 

Kamera v Blenderu představuje objekt, který nelze nijak editovat, proto pro ni 
existuje jen objektový režim s jejími vlastnostmi. Ve scéně může být v jednu chvíli více 
kamer, avšak musíme mít na paměti, že pohled kamerou (NumPad 0) bude vždy brán 
z kamery aktivní. Kameru jako aktivní nastavíme tak, že si požadovanou kameru označíme 
a pak přes rozbalovací nabídku View>Cameras>Set Active Obejct as Active Camera 
provedeme příslušný příkaz. S kamerou lze provádět běžné transformační příkazy tak, aby 
natočení kamery na objekt bylo pro uživatele optimální. 

Jestliže máme kameru vybranou, přepneme se do editačního menu v okně Buttons 
Window. Vidíme zde panel s nápisem Camera (obrázek 37). Ten obsahuje následující 
možnosti. Číselné tlačítko Lens, jímž měníme čočku kamery. To znamená, že se přibližuje 
či oddaluje pohled ve scéně. Jestliže bychom chtěli zapnout ortografické renderování 
scény, provedeme to tlačítkem Orthographic (ortografické promítání je takové promítání, u 
kterého není zkreslována velikost objektů se vzdáleností kamery [1]). Tlačítko Limits 
způsobí, že se na obrazovce objeví úsečka, která určuje oblast viditelnosti kamery. To 
znamená, že to co je mimo oblast úsečky kamera neuvidí. Vzdálenost této úsečky můžeme 
měnit numerickými tlačítky Start, End. Tlačítko Name nám v pohledu kamery zobrazí 
jméno objektu, tudíž kamery. Title Safe v pohledu kamery zapíná a vypíná zobrazení 
vnitřního čerchovaného obdélníku, který slouží pro centrování kamery. Číselným tlačítkem 
Dot Dist měníme vzdálenost ohniska od polohy kamery v ose. Tlačítko Passepartout nám 
zatemní oblast, která nebude zobrazena při vykreslování. Zmíněnou velikost zatemnění 
můžeme měnit posuvným tlačítkem Alpha. Size mění velikost kamery. Numerická tlačítka 
pod nápisem Shift mění směr pohledu kamery v osách x a y.  
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Obrázek 37 - Panel pro práci s kamerou 
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8 Vykreslování (rendering) 

Renderování představuje souhrn matematických výpočtů fyzikálních náležitostí, 
které ve scéně simulujeme. Výsledkem takových výpočtů je bitmapový obraz nebo 
animace, které by měly co nejvíce odpovídat našim představám [1]. V této kapitole si 
projdeme nejdůležitější možnosti renderingu. 

Nastavení pro render zpřístupníme v okně Buttons Window, klepnutím na ikonu 
Scene nebo klávesovou zkratkou F10. V této chvíli bychom měli vidět sedm panelů. Dva 
z nich, Render Layers a Bake vynecháme a probereme je až v praktické části bakalářské 
práce. Pojďme si probrat ty nejdůležitější. Kompletní popis tlačítek bude uveden 
v praktické části bakalářské práce. 

 

Obrázek 38 - Panely pro nastavení renderu 

V prvním panelu Output se nastavují vlastnosti pro výstup souborů. Nejdůležitějším 
prvkem v tomto panelu je formulářové pole, ve kterém je text /tmp\. Kliknutím na ikonku 
adresáře v tomto poli můžeme změnit cestu k adresáři, kam bychom chtěli ukládat výstupní 
soubory. Do adresáře se automaticky ukládá posloupnost obrázků, ale bitmapový obrázek 
se musí po vykreslení samostatně uložit pomocí příkazu Save Rendered Image v nabídce 
File. Nalezneme zde i devět neoznačených tlačítek na levé spodní části panelu, které 
udávají, ve které části obrazovky se má renderovaný obrázek zobrazit. 

Dalším panelem je Render, kde se nacházejí příkazy pro samotné renderování. 
Nejdůležitějším příkazem je tu tlačítko Render, které provede vykreslení (klávesa F12). 
Šest tlačítek vedle hlavního tlačítka Render slouží pro zahrnutí příslušného algoritmu do 
výpočtu pro vykreslení. Jsou to například pro výpočet stínů Shadow, pro částečné 
prozařování paprsků pod povrch (SSS), pro panoramatický rendering (Pano), pro zrcadlení 
(EnvMap), pro ray tracing (Ray) a pro simulaci přirozeného osvětlení objektů (Radio). Pod 
tlačítkem OSA se skrývá antialiasing (vyhlazování hran), z toho vyplývá, že získáme 
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kvalitnější obraz na úkor renderovací doby, kterou určují číselná tlačítka pod tlačítkem 
OSA. Tlačítka Xparts a Yparts udávají, na kolik částí se má vykreslování rozložit ve 
vodorovném a svislém směru. Jestliže tu tedy máme v obou číselných tlačítkách vyplněny 
čtyřky, renderování se rozloží na 16 částí (4 x 4). 

Třetí panel Anime má podobné tlačítko, jako měl panel Render, tudíž zde 
nalezneme tlačítko Anime, které spustí výpočet animace. Položky Sta a End udávají, které 
snímky se budou započítávat do animace. Tlačítko Play se používá pro přehrání animace, 
která již byla jednou spočítána. 

Předposledním panelem je Format, kde se nastavují vlastnosti obrazů a animací. 
Položkou SizeX a SizeY nastavujeme rozlišení výstupního obrazu či animace v pixelech. 
Tyto položky můžeme zadat ručně, nebo použijeme některý ze standardů v pravé části 
panelu (Pal, NTSC, HD, aj.). Další velmi důležitou volbou je rozbalovací menu s nápisem 
jpeg. Zde si vybíráme výstupní formát bitmapy nebo animace, který musí být zadán ještě 
před výpočtem animace, protože se animace automaticky ukládá do jednoho nebo více 
souborů. Kdybychom si například vybrali nějaký bitmapový formát a spustili výpočet 
animace, získali bychom tím posloupnost obrázků. Položky BW, RGB a  RGBA slouží pro 
nastavení barev ve výstupním obrazu. Tlačítko PS udává tzv. počet snímků za sekundu, 
což znamená, že jestli animace bude mít 100 snímků a hodnota PS bude nastavena na 25, 
výsledná animace bude trvat 4 sekundy. 

Posledním panelem je Stamp, díky kterému můžeme do obrázku nebo animace 
vkládat nějaké informace. Například to může být jméno souboru, čas vytvoření nebo 
nějaký vlastní text.  
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9 Animace, efekty a jejich vytvá ření 

Blender při vytváření animací používá různé techniky či nástroje. V první části této 
kapitole si povíme jak vytvořit jednoduché animace pomocí vkládání animačních klíčů, 
kterými můžeme například posun objektu či jeho deformace. Další složitější animace, se 
vytvářejí pomocí IPO editoru. 

9.1 Vytvá ření jednoduché animace 

Při jednoduchých animacích nám postačí, budeme-li vkládat animační klíče do 
jednotlivých snímků. Animační klíče jsou takové klíče, které definují průběh animace 
v jednotlivých snímcích. Tedy mohou měnit polohu objektu, natočení, velikost nebo 
mohou deformovat objekt. Aktuální číslo snímku nalezneme jako numerické tlačítko na 
panelu Buttons Window. Nyní si již řekněme, jak se vkládají animační klíče. Vybereme si 
objekt, se kterým chceme provádět animaci. Poté ve snímku 1 vložíme animační klíč přes 
nabídku Object>Insert Keyframe (nebo klávesa I ). Na obrázku 39 můžeme tuto nabídku 
vidět i s jejími možnostmi animačních klíčů, které chceme vložit. Máme tu klíče, které 
provádějí vždy nějaké specifické úkony. Například Loc pro změnu polohy, Rot pro otočení, 
Size pro změnu měřítka či kombinované LocRot pro změnu polohy i otočení najednou aj. 
Pokud vložíme animační klíč například nad materiálovým menu, změní se nám nabídka 
animačních klíčů. To znamená, že zde budou klíče pro změny barev či průhlednosti apod. 

V praktické části bude demonstrován příklad na jednoduchý příklad. 

 

Obrázek 39 - Rozbalovací nabídka pro výběr animačních klíčů 
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9.2 Animace dle IPO editoru 

Jestliže bychom chtěli vytvářet složitější animace, tedy s více animačními klíči, 
stává se jejich správa obtížná. Proto má Blender tzv. IPO editor, který nám dovoluje 
snadněji pracovat s animačními klíči. IPO editor je v Blender reprezentován jako 
samostatné okno, tudíž se do něj přepneme (obrázek 40). 

 

Obrázek 40 - IPO editor 

Pojďme si popsat, co vše tu nalezneme. V levé části je svislá osa grafické závislosti 
(4) pro polohu, rotaci, barvu aj. Další vodorovná osa závislosti ve spodní části okna určuje 
číslo snímku (5). V pravé části můžeme nalézt seznam vlastností (3), jejichž výběrem se 
nám zobrazí animační křivka (2) se stejnou operací. Klíče jsou tu zobrazovány jako černé 
body na animační křivce. Zelená svislá přímka (1) představuje v IPO editoru aktuální 
snímek. 

Každou animační křivku můžeme vybrat stejným způsobem, jakým pracujeme 
s objekty. Jestliže vybereme nějakou vlastnost ze seznamu vlastností, zobrazí se k ní 
křivka, která je s touto vlastností spjata. Výběr více animačních křivek najednou zajistíme 
podržením klávesy Shift a postupným výběrem vlastností. Jestliže vlastnost nemá žádnou 
křivku, můžeme ji vytvořit tak, že klikneme na prázdnou vlastnost a pak za držení klávesy 
Ctrl  klikneme do grafu. Tím vytvoříme nový animační klíč a tím i animační křivku. 

Na obrázku 40 vidíme animační křivky, příkladu z kapitoly 9.1.1, který je uveden 
v praktické části bakalářské práce. Jednalo se o příklad, kdy se na krychli použili různé 
transformace v různých snímcích. Pro lepší představu si pojďme ze zmíněného obrázku 
vysvětlit, co se animace provede. V první části jsme měli krychli umístěnou ve vzdálenosti 
3 od počátku na ose x. Tudíž zde máme i klíč a animační křivku, která je spjata s vlastností 
LocX. Měníme tedy polohy v ose x. Můžeme vidět, jak křivka klesá do bodu 0, kde má na 
snímku 70 určen další animační klíč. Od tohoto snímku krychle opět mění polohu, ale 
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v ose y a také se pootočí o 45° v ose z. Můžeme tedy vidět jak křivky s vlastností LocY a 
RotZ mění svou hodnotu až do dalšího animačního klíče na snímku 150. Od toho snímku 
probíhá poslední transformace, kde se krychle pohybuje opět po ose x (LocX) a mění své 
měřítko ve všech osách (ScaleX, ScaleY, ScaleZ) až do snímku 250. 

S animačními klíči lze pracovat ještě v jednom speciálním režimu, ve kterém je 
každým animačním klíčem vedena svislá přímka. Dostaneme se k němu přes nabídku 
v okně IPO editoru (View>Show Keys). Tyto přímky můžeme vybírat a posouvat je 
v horizontálním směru a tím měnit umístění klíčů. V tomto režimu si můžeme nechat 
zobrazit animační klíče ve 3D scéně. Provedeme to tak, že v okně Buttons Window  v menu 
Object stiskneme tlačítko Draw Key na panelu Anim Settings. 
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10 Částicové systémy a efekty 

Částicové systémy jsou silným nástrojem pro simulaci různých fyzikálních efektů. 
Základem je objekt typu mesh, který slouží jako emitor částic. Tyto částice můžeme 
ponechat v implicitní podobě, nebo jim můžeme přiřazovat tvary jiných objektů (mesh, 
curves, metaballs). Jejich praktické využití nalezneme například při simulaci kouře, ohně, 
exploze, deště, sněhu a podobně [1]. 

V této kapitole si ukážeme, kde částicový systém v Blenderu nalezneme, a jeho 
způsoby nastavení. Dále si popíšeme základní práce pro simulace efektů, jako jsou 
například látkové nebo pružné objekty. Konkrétní příklady na částicové systémy a tvorbu 
efektů budou uvedeny v praktické části mé bakalářské práce. 

10.1 Nastavení částicového systému 

Nastavení částicového systému nalezneme v okně Buttons Window, v nabídce 
Object kde nalezneme tlačítko s názvem Particle buttons (1), který vidíme na obrázku 41. 
Po přepnutí vidíme, že tu nic není z toho důvodu, že nejdříve musíme částicový systém 
objektu přiřadit. Částicový systém objektu přiřadíme pomocí tlačítka Add New. Po zadání  
příkazu nám přibude 6 nových panelů, které můžeme vidět na obrázku 41, 42. Pojďme si 
popsat, pro co každý panel slouží. 

 

Obrázek 41- Panely Particle system, Bake a Physics 

Prvním panelem Particle System přiřazujeme tedy objektu částicový systém. 
Jednomu objektu lze přiřadit více částicových systémů. Na kolikátém systému jsme, určuje 
číselné tlačítko v pravé horní části panelu, kde je uvedeno 1 Part 1. Jestliže máme k 
objektu přiřazeno více systému, můžeme se tak mezi nimi přepínat klepnutím na pravou 
část tlačítka. Jestliže jsme na posledním, můžeme přidat další systém. Pod textovým polem 
s názvem systému se nachází rozbalovací nabídka s možnostmi pro výběr typu částicového 
systému. Nabídka obsahuje Emitter, který vydává pohyblivé částice. Možností Reactor 
vznikají částice, které mohou být vydávány ze stejného nebo jiného objektu. Poslední 
volbou Hair se vytvářejí tzv. statické částice, které se využívají například pro generování 
chlupů nebo vlasů. 
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Pod textem Basic následuje řada číselných tlačítek. Tlačítko Amount určuje počet 
částic. Do tlačítek Sta a End zapisujeme čísla snímků, ve kterém se mají částice vytvářet či 
přestat vytvářet. Tlačítkem Life udáváme, jak dlouho bude částice ve scéně. To znamená, 
že vznikne-li na padesátém snímku (Life máme nastavený na 50),  na stém snímku zanikne. 
Poslední tlačítko Rand úzce souvisí s Life, kde zadáváme náhodný faktor životnosti částic. 

Pod textovým polem Emit From máme možnosti pro generování částic z elementů. 
Tlačítkem Random udáváme, že částice se budou generovat nepravidelně. Tlačítko Even 
určuje, jestli budou částice vytvářeny v závislosti na geometrii objektu. Rozbalovací 
nabídka s nápisem Faces (plochy) a s dalšími možnostmi Verts (vertexy) a Volume (vnitřek 
mesh objektu) udávají, odkud se budou částice vytvářet. Další rozbalovací nabídka 
s možnostmi Jittered, Random a Grid má vliv na rozmístění částic. 

Další panel s názvem Bake se používá pro „zapékání“. Zapékání je předpočítání 
chování částic, které provedeme tlačítkem Bake. Předpočítání se ukládá na disk a při 
případném renderingu se tyto data využívají. Tlačítka Start a End udávají, které snímky se 
mají předpočítat. Jestliže provedeme zapékání a budeme chtít provést nějaké změny, 
musíme nejdříve provést uvolnění zapékání tlačítkem Free Bake, které se objeví na stejné 
pozici. 

Následujícím panelem s názvem Physics určujeme fyzikální chování částic. První 
rozbalovací nabídka s názvem Newtonian, která specifikuje základní chování částic. Máme 
zde následující možnosti: 

• None – všechny částice jsou trvale připojeny k mesh objektu [1]. 

• Newtonian – standardní a hodně často používané nastavení. Částice se 
pohybují na základě nastavených parametrů [1]. 

• Keyed – částice směřují k jinému objektu s přiděleným částicovým 
systémem [1]. 

• Boids – částice se chovají na základě jednoduché umělé inteligence [1]. 

Při změně každé možnosti si můžeme všimnout, že se nám mění i panel Psychics, 
tudíž si popíšeme možnosti dle volby Newtonian, která se používá nejčastěji. Další 
rozbalovací nabídka, která se nachází vpravo od minulé nabídky, slouží pro výběr 
fyzikálních integrátorů (způsob výpočtu chování částic). Na výběr zde máme tři volby. 
První z nich je Euler, kde jsou výpočty nejméně přesné ale na druhou stranu nejrychlejší. 
Druhá volba Midpoint, kde jsou výpočty akceptovatelné, ale doba výpočtu trvá o něco 
déle. Posledním nejpřesnějším integrátorem je RK4, ale rychlost jeho výpočtů je 
nejpomalejší. 

Pod textovým polem Initial Velocity najdeme následující číselná tlačítka. 
Numerické tlačítko Object určuje, zda se emitor pohybuje. Na tlačítku Normal určujeme 
počáteční rychlost částic ve směru normály. Random udává náhodný faktor k počáteční 
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rychlosti Normal. Tlačítkem Tan zadáváme počáteční rychlost ve směru tečného vektoru a 
Rot otáčí tečným vektorem. 

Pod popisem Rotation nalezneme příkazy pro určení rotace částic. Tlačítkem 
Dynamic způsobíme, že se částice budou chovat na základě chování okolí. Rozbalovací 
nabídka hned vedle tlačítka Dynamic udává směr částic na počátku. Tlačítkem Random 
přidáváme náhodný faktor počátečního směru. Poslední rozbalovací nabídka určuje rotaci 
částic v průběhu animace. 

Jedny z posledních tlačítek v panelu Physics jsou Acc X, Acc Y a Acc Z, které určují 
rychlost pohybu částic v příslušné orientaci. Tlačítkem Drag zpomalujeme pohyb částic. 
Brownian slouží pro náhodný pohyb částic v tekutinách a Damp specifikuje vnitřní tření 
částic. 

 

Obrázek 42 - Panel Visualization, Extras a Children 

Čtvrtým panelem Visualization určujeme vzhled částic ve scéně i při renderování. 
Nejdůležitějším faktorem je rozbalovací nabídka v horní části panelu, kde si zvolíme 
podobu jednotlivých částic. Možnostmi této nabídky jsou None (částice se nebudou 
vykreslovat), Point (vykreslují se jako body), Circle (jako kružnice), Cross (jako kříže), 
atd. 

Panel Extras slouží jako panel pro příkazy částic, které se nikam jinam nevešly. 
Effector určuje reakce částic na jiné vlivy (vítr). Příkazy pod textovým polem Time udávají 
nastavení cyklické životnosti částic, nebo urychlují či zpomalují čas pro fyzikální chování 
částic. Příkazem Seed zabraňujeme, aby jiné objekty se stejným částicovým systémem 
nevytvářely stejné hodnoty. 

V poslední panelu s názvem Children se určují potomci, to znamená, že vznikají 
nové částice podle rozbalovací nabídky v horní části panelu [1].  Z rozbalovací nabídky 
máme možnosti None (žádní potomci), Particles (potomci vznikají z částic) nebo Faces 
(potomci vznikají z ploch). 

10.2 Práce s efekty 

Tak jako jsme pro částicové systémy měli nabídku Particle buttons, máme i stejné 
seskupeni pro práci se simulováním efektů. Tuto nabídku nalezneme taktéž v okně Buttons 
Window v menu Objects pod tlačítkem Psychics buttons, hned vedle tlačítka Particle 
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buttons. Po kliknutí na tlačítko Psychics buttons zde uvidíme celkem 9 panelů, které 
skýtají nejrůznější možnosti. Pojďme si některé představit. 

10.2.1 Efekty látek 
Na obrázku 43 můžeme vidět tři panely, které pracují se simulací látek. Jsou to 

panely Cloth, Cloth Collision a Cloth Advanced. 

 

Obrázek 43 - Panely Cloth, Cloth Collision a Cloth Advanced 

Panel Cloth určuje, jaké vlastnosti bude látka mít. Nejdůležitějším prvkem tohoto 
panelu je rozbalovací nabídka, kde si vybíráme, jaký typ látky požadujeme. Jelikož každá 
látka má své unikátní vlastnosti, stačí si jen z této nabídky vybrat, a ostatní parametry se 
nastaví automaticky. Na výběr tu máme z šesti přednastavených možností. Leather (kůže), 
Denim (džínovina), Rubber (hadr), Cotton (bavlna), Silk (hedvábí) a poslední možnost je 
Custom, kde si uživatel může sám nadefinovat látku [3]. 

Zmíněné vlastnosti látky nalezneme v numerických tlačítkách pod rozbalovací 
nabídkou. Jsou to Struct Stiff udávající tuhost struktury látky. Do Bend Stiff zadáváme 
parametry pro tuhost látky v ohybu. Spring Damp pro vnitřní tření, Air Damp pro tření 
vzduchu. Dále Quality pro vzhled látky při animaci. Hodnotou Mass určujeme hmotnost 
látky a Gravity určuje působení gravitace na látku v jednotlivých osách. Poslední tlačítko 
Pinning of cloth se používá pro uchycení vertexů látky.  

Panel Cloth Collision nám slouží pro příkazy, které řeší chování látky při kolizi 
s jinými objekty. Tlačítko Bake s numerickými tlačítky Sta a End mají stejný význam jako 
u částicových systémů. Tlačítko Enable collisions umožňuje kolizi látky s jinými objekty. 
Tlačítkem Min Distance určíme hodnotu (vzdálenost), při které se bude počítat kolize. 
Collision Quality určuje kvalitu a přesnost výpočtu kolizí. Tlačítkem Friction udáváme 
tření mezi látkou a kolizním objektem. Poslední tlačítko Enable selfcollison povoluje či 
zakazuje kolizi mezi částmi látky. 

Posledním panelem Cloth Advanced nastavujeme pokročilá nastavení, které lze 
aplikovat jen na seskupení vertexů. Jestliže tedy nemáme vytvořeno žádné seskupení 
vertexů, tento panel nic nezobrazuje. Vybraným seskupením lze pak zadávat maximální 
tuhost při napínání (Struct Stiff Max) a ohýbání (Bend Stiff Max). 

10.2.2 Efekty pružných objekt ů 
V této části kapitoly si popíšeme panely pro nastavení objektů, které se nějakým 

způsobem odráží nebo jsou pružné. Pro tyto operace se používají panely Collision, Soft 
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Body, Soft Body Collision, Soft Body Solver. Všechny tyto panely můžeme vidět na 
obrázku 44. 

 

Obrázek 44 - Panely pro správu pružných objektů 

První panel Collision slouží pro označení objektu jako kolizního. Označení objektu 
jako kolizního znamená, že jiné objekty (částice, látkové objekty) jimi nemohou procházet. 
V horní části tohoto panelu pod textovým polem Particle Interaction se nacházejí 
nastavení pro kolize s částicemi. Nalezneme zde tlačítka pro tlumení (Damping) a pro tření 
(Friction). Každé z těchto tlačítek má vedle sebe tlačítko Rand, které k nim určuje náhodný 
faktor. Stisknuté tlačítko Kill způsobí, že částice při kolizi zanikají. Tlačítkem Permeability 
nastavíme možnost průchodu částic skrz mesh objekt. 

Nastavení ohledně pružných a látkových objektů nalezneme pod textovým polem 
Soft Body and Cloth Interaction. Zde můžeme tlačítkem Damping nastavit tlumení během 
kolize. Tlačítka Inner a Outer určují vnitřní a vnější tloušťku plochy. Tlačítkem Absorption 
udáváme procentuální hodnotu, která udává ztrátu síly efektu při kolizi s objektem. 
Tlačítkem Ev. M. Stack se provede operace, kterou odebereme kolizní objekt 
z modifikátorů. 

Panel Soft Body nastavuje parametry objektu, které jsou tlačítkem Soft Body určeny 
jako pružné. Tlačítkem Friction nastavuje obecné tření pružného objektu vzhledem 
k okolí. Mass určuje hmotnost vertexů. Tlačítkem Grav zadáváme gravitaci vzhledem 
k ose z. Tlačítkem Speed určujeme rychlost celé animace. Tlačítkem Use Goal 
zpřístupňujeme příkazy, které slouží pro seskupení vertexů. Těmito skupinami můžeme 
určit, aby se část objektu chovala jinak. Use Edges povoluje pružnost u hran. Stiff Quads 
způsobí, že se na čtyřúhelníkové plochy přidají pomyslné úhlopříčky, na které bude 
aplikována pružnost. C Edge a C Face dovolí kolizi hran a ploch. Tlačítky Push a Pull 
měníme tuhost a velikost objektů proti klidovému stavu. Příkazem Damp určujeme tření 
v hranách. SL provádí změnu velikosti objektu při kolizi. Tlačítko udává rychlost padání 
objektu ve směru k zemi. Posledními tlačítky Plas určujeme stálou deformaci a Be určuje 
tuhost při deformaci. 
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V třetím panelu s názvem Soft Body Collision nacházíme tlačítko Bake, jehož 
využití již známe. Tlačítko Self Collision udává možnost kolize samo se sebou. Tato kolize 
se počítá za pomoci koule, které můžeme nastavovat různé parametry. 

Panel Soft Body Solver obsahuje výpočtové metody pro specifičtější chování 
pružných objektů. Metoda SOFT zajišťuje stabilnější chování pružných objektů. Metoda 
RKCP je méně stabilní, ale je vývojáři doporučená jako výuková. 
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11 Skriptování 

Skripty v Blenderu umožňují nejrůznější operace, které jeho možnosti rozšiřují. 
Tyto programy se vytvářejí za pomoci jazyka Python. Python je dynamický objektově 
orientovaný skriptovací jazyk, který je stejně jako Blender open source [6]. Jelikož naučit 
se programovat Python skripty na vyšší úrovni je složité, bude nám stačit ukázka skriptu, 
který vytvoří základní geometrické těleso. Tato ukázka bude demonstrována v praktické 
části bakalářské práce jako jedna z lekcí výukového kurzu. Nyní si ale pojďme ukázat, kde 
se v Blenderu skripty píší a jak se dají kompilovat. 

Přidejme si do scény ještě jedno okno a nastavme si ho jako Text Editor, poté už 
v tomto okně stačí naprogramovat skript dle libosti. Další možností je, že si již nějaký 
hotový skript stáhneme z internetu a v tomto okně si jej otevřeme (nabídka Text>Open), 
popřípadě zeditujeme. Tyto skripty mají příponu *.py. Dále přes nabídku Text>Run Python 
Script můžeme daný skript spustit. Jestliže je vše v pořádku, skript se provede. V opačném 
případě nás Blender upozorní na případné chyby. Další možností otevření Python skriptu 
je, že spustíme soubor s příponou *.blend, ve kterém je již skript hotov. Po otevření 
souboru se nám skript ukáže již ve zmíněném okně Text Editor, nebo se rovnou spustí. Na 
obrázku 45 můžeme vidět jednoduchý skript (vytvoření jehlanu), který bude prezentován 
v praktické části bakalářské práce. 

V mnoha případech se můžeme setkat, že skripty nebudou funkční. I já jsem se s 
touto nepříjemností setkal. Důvodem je, že skripty jsou staré a jak se vyvíjí Blender, tak se 
mění i podpora jazyka Python. K vyřešení tohoto problému je nutné, abychom určitý skript 
přeprogramovali [5]. 

 

Obrázek 45 - Okno Text Editor se skriptem 
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12 Tvorba webové prezentace 

Webová prezentace neboli praktická část mé bakalářské práce zde reprezentuje 
znalosti získané během teoretické části. Díky webu můžeme využít multimediálních 
vlastností, které jsou pro výuku v programu Blender podstatné. Výukové pásmo je 
navrhnuto na kapitoly, které si jako v předchozí části vysvětlíme a doplníme názornými 
příklady. Tyto příklady budou navíc doplněny multimediálními ukázkami pro lepší 
orientaci v příkladu. 

12.1 Koncepce vytvá ření webové prezentace 

Jak jsme si řekli v předchozím odstavci, výukové pásmo (WWW stránky) je 
členěno na jednotlivé lekce tak, aby začínajícímu uživateli poskytlo dostatek informací pro 
zvládnutí ovládání Blenderu. Každá lekce má takovou strukturu, že daná problematika je 
vysvětlena nejdříve teoreticky. Dále jsou uvedeny praktické interaktivní návody v různém 
stupni rozpracovanosti, aby byla látka co nejlépe pochopitelná. Na konci každé kapitoly 
jsou přikládány k dispozici zdrojové soubory ve fázi úplného dokončení dané lekce a také 
multimediální ukázky. 

Webové stránky jsou tvořeny za pomoci jazyka XHTML , PHP a CSS stylů. 

12.2 Umíst ění webové prezentace  

Webovou prezentaci jsem umístil na free hosting serveru Internet Centrum (IC.cz), 
jehož provozovatelem je firma Nodus Technolgies s.r.o. Internetová adresa mé webové 
prezentace je http://blender-education.ic.cz/. Tento webhosting jsem si vybral z důvodu, že 
s ním mám dobré zkušenosti a zatím jsem se nesetkal s výraznými potížemi. 

12.3 Tvorba videí a jejich umíst ění na internetu 

Pro tvorbu videí jsem si vybral program Camtasia Studio 7.1.0. Tento program 
slouží pro snímání obrazovky počítače a jeho další funkcí je, že tyto videa dokáže zároveň 
upravovat. Na obrázku 46 můžeme vidět prostředí toho programu. Můžeme zde vidět 
ukázku upravovaného videa. 

V levé části obrazovky je okno, které funguje pro otevírání souborů. Jeho další 
funkcí je, že můžeme do videa přidávat nové entity (např. text, zvukové stopy, efekty 
kurzoru myši, aj.). V pravé části programu nalezneme přehrávač, který pracuje s videem 
v reálném čase. Posledním panelem tohoto programu je časová osa videa, která se nachází 
ve spodní části. V tomto panelu se nám zobrazují modifikace, které s videem provádíme. 
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Obrázek 46 - Program Camtasia 

Snímání obrazovky je realizováno pomocí modulu tohoto programu (obrázek 47). 
V modulu si můžeme přednastavit velikost snímané plochy. Dále je tu možnost nahrávání 
přes webovou kameru či zaznamenávání zvukové stopy. Tlačítko rec spustí nahrávání 
obrazovky. Tlačítkem F10 můžeme nahrávání ukončit. 

 

Obrázek 47 - Modul programu Camtasia pro snímání plochy 

Velikou výhodou programu je možnost okamžitého umístění videa na internet, což 
je také jedním z důvodů, proč jsem si tento software vybral. V mém případě jsem si vybral 
internetový portál YouTube, který patří mezi největší portály na světě. Má práce by měla 
být veřejná a je zaměřena jako výukový kurz, proto pro mě byla volba YouTube 
samozřejmostí. Další nespornou výhodou je vložení videa na mou webovou prezentaci 
pomocí jejich interního přehrávače. 
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13 Závěr 

Práce na tomto projektu byla pro mne přínosná hned v několika směrech. Největším 
hlediskem bylo, že jsem se s 3D modelováním seznámil v souvislosti s jinými 
programovými produkty, proto mě výuka samotného Blenderu otevřela možnosti celé 3D 
scény. Dalším aspektem, který mě obohatil, bylo vytvořit výukové pásmo tak, aby jej 
zvládl i úplný začátečník, který by se také rád něco dozvěděl o modelování ve 3D. Vžil 
jsem se tak do situace začátečníka, pro kterého je toto prostředí zcela nové. Proto má snaha 
směřovala k přehlednosti, srozumitelnosti a k tomu, aby bylo vše podstatné zdůrazněno. 
V neposlední řadě bylo pro mě přínosné vytvoření webového výukového pásma. 

Má práce je orientována spíše na obecné pochopení pojmů, které se ve 3D scéně 
vyskytují, a na návod, jak s nimi v Blenderu pracovat. Mou snahou na tomto projektu bylo, 
abychom se s tímto programem setkali krok po kroku, a nepředbíhali tak jiné kapitoly, což 
by mohlo být pro začínajícího uživatele matoucí. Výukové pásmo vybízí uživatele k 
experimentování s jednotlivými lekcemi, díky čemuž objevuje nové možnosti Blenderu. 
Všechny tyto lekce výukového pásma jsou navrženy tak, aby k nim měl uživatel vždy 
přístup a mohl se jim tak věnovat sám. 

Jelikož tento program skýtá opravdu nepřeberné množství možností, není kurz 
zaměřen na zvládnutí všech funkcí Blenderu, nebylo by to obsahově možné. Proto má 
práce klade důraz na výuku začátečníků a mírně pokročilých uživatelů a jejich uvedení do 
modelovacích a animovacích metod Blenderu. 

Webový projekt byl již mou finální prací a je samotnou prezentací tématu 
bakalářské práce.  
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